[pve-devel] trying to upgrade wheezy -> jessie + corosync1 ->corosync2

Dietmar Maurer dietmar at proxmox.com
Wed Apr 29 13:20:43 CEST 2015


> This dependency come from clvm package
> 
> from which depend (old) libpve-storage-perl version. (not yet updated).
> 
> forcing install of libpve-storage-perl with dpkg -i --force .deb  seem to
> resolve it.
> 
> Maybe adding a trick like "provides: clvm " in a proxmox package could work ?

IMHO such hacks are very fragile.

But we always provided an upgrade script in previous releases. That script can
simply remove those conflicting packages before you run the upgrade.
Would that work?



More information about the pve-devel mailing list