[pve-devel] trying to upgrade wheezy -> jessie + corosync1 ->corosync2

Alexandre DERUMIER aderumier at odiso.com
Wed Apr 29 12:50:54 CEST 2015


Seem that update try to install libdlm3 from jessie repository,
and conflict with redhat-cluster-pve

Préparation du dépaquetage de .../libdlm3_3.1.8-1.2+b1_amd64.deb ...
Dépaquetage de libdlm3 (3.1.8-1.2+b1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libdlm3_3.1.8-1.2+b1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/libdlm.so.3.0 », qui appartient aussi au paquet redhat-cluster-pve 3.2.0-2


This dependency come from clvm package

from which depend (old) libpve-storage-perl version. (not yet updated).

forcing install of libpve-storage-perl with dpkg -i --force .deb  seem to resolve it.

Maybe adding a trick like "provides: clvm " in a proxmox package could work ?





They are also some other old packages, not yet upgraded, depending on specific perl version 

 libcrypt-openssl-random-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libtext-iconv-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 lsof : Dépend: libperl4-corelibs-perl mais ne sera pas installé ou
                 perl (< 5.12.3-7) mais 5.20.2-3 devra être installé



----- Mail original -----
De: "dietmar" <dietmar at proxmox.com>
À: "aderumier" <aderumier at odiso.com>
Cc: "pve-devel" <pve-devel at pve.proxmox.com>
Envoyé: Mardi 28 Avril 2015 20:10:38
Objet: Re: [pve-devel] trying to upgrade wheezy -> jessie + corosync1 ->corosync2

> Tommorow,I'll try again to do some upgrade from wheezy. 
> I think it's missing a conflict somewhere in new corosync package (related to 
> dlm) and old redhat cluster suite. 
> It was a little bit tricky to upgrade with aptitude. 

Thanks. It would be great if you can track that down. 


More information about the pve-devel mailing list