[pve-devel] trying to upgrade wheezy -> jessie + corosync1 ->corosync2

Alexandre DERUMIER aderumier at odiso.com
Wed Apr 29 13:33:39 CEST 2015


>>But we always provided an upgrade script in previous releases. That script can 
>>simply remove those conflicting packages before you run the upgrade. 
>>Would that work? 

Yes,It should work

I'm retrying upgrade again,

it's seem that

#apt-get update
#apt-get remove clvm
  ->(upgrade libpve-storage-perl  automaticaly)
#apt-get dist-upgrade

is working

Need to do more tests to be sure

----- Mail original -----
De: "dietmar" <dietmar at proxmox.com>
À: "aderumier" <aderumier at odiso.com>
Cc: "pve-devel" <pve-devel at pve.proxmox.com>
Envoyé: Mercredi 29 Avril 2015 13:20:43
Objet: Re: [pve-devel] trying to upgrade wheezy -> jessie + corosync1 ->corosync2

> This dependency come from clvm package 
> 
> from which depend (old) libpve-storage-perl version. (not yet updated). 
> 
> forcing install of libpve-storage-perl with dpkg -i --force .deb seem to 
> resolve it. 
> 
> Maybe adding a trick like "provides: clvm " in a proxmox package could work ? 

IMHO such hacks are very fragile. 

But we always provided an upgrade script in previous releases. That script can 
simply remove those conflicting packages before you run the upgrade. 
Would that work? 


More information about the pve-devel mailing list