[PVE-User] sbin/unconfigured.sh

Steve steve at easy2boot.com
Fri May 19 09:36:46 CEST 2017

As an experiment, I even inserted a dd'd flash drive containing the proxmox
ISO (which works if I boot to it) and then booted from my multiboot USB
drive to the shell and then mounted /mnt as the flash drive
mount /dev/sdc /mnt

then I ran the modified script.
I gave the same fail message.
So that seems to indicate that something is wrong with the script or
environment when I run the script?

The script I run starts with
if [ -f /mnt/pve-installer.squashfs ]; then
    echo this is a Proxmox VE installation CD

    if ! mount -t squashfs -o ro,loop /mnt/pve-base.squashfs
/mnt/.pve-base; then
debugsh_err_reboot "mount pve-base.squashfs failed"

any ideas what is not set up before this?


On 19 May 2017 at 07:34, Fabian Grünbichler <f.gruenbichler at proxmox.com>

> On Thu, May 18, 2017 at 07:08:36PM +0100, Steve wrote:
> > Thanks for the quick reply.
> > I am booting from the ISO file itself which is on a multiboot USB drive.
> > In previous versions, you could boot to the shell, mount the ISO as /mnt
> > and then start the install by running unconfigured.sh.
> >
> > So basically, if I boot to the shell, how can I start the install from
> the
> > contents of the CD/ISO.
> >
> you need to mount the contained squashfs files in the right order on the
> right places, make an overlayfs and then bind mount the iso into that.
> then you can chroot and run the unconfigured.sh script. basically do all
> the steps that the initrd contained on the iso does ;)
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user

More information about the pve-user mailing list