[PVE-User] Problem Cloning Disk

Lindsay Mathieson lindsay.mathieson at gmail.com
Wed Mar 25 12:28:33 CET 2015

On Wed, 25 Mar 2015 08:56:36 PM you wrote:
> Getting this error ever time I try to clone a VM or move its disk
> Src Disk is a ceph rbd image. I've tried using ceph rbd as the dest with the
> same error.
> create full clone of drive virtio0 (ceph1:vm-201-disk-1)Formatting
>  '/mnt/cephfs/images/201/vm-201-disk-1.qcow2', fmt=qcow2
> size=136365211648 encryption=off cluster_size=65536
> preallocation='metadata' lazy_refcounts=off transferred: 0 bytes remaining:
> 136365211648 bytes total: 136365211648 bytes progression: 0.00 %qemu-img:
> output file is smaller than input fileTASK
>  ERROR: storage migration failed: copy failed: command
> '/usr/bin/qemu-img convert -t writeback -p -n -f raw -O qcow2
> 'rbd:rbd/vm-201-
> disk-1:mon_host=\:6789\;\:6789\;\:6789\;
> :id=admin: auth_supported=cephx:keyring=/etc/pve/priv/ceph/ceph1.keyring'
>  /mnt/cephfs/images/201/vm-201-disk-1.qcow2' failed: exit code 1

I'm running a cmd line clone of the disk now, without the "-n" parameter. That 
is working.

Could there be an issue with calculating the disk size on rbd images?

More information about the pve-user mailing list