[PVE-User] Problem Cloning Disk

Alexandre DERUMIER aderumier at odiso.com
Thu Mar 26 13:18:26 CET 2015

>> '/mnt/cephfs/images/201/vm-201-disk-1.qcow2',

why do you use qcow2 file on top of cephfs ??????????

you should use ceph as a block device through rbd.

(performance will be awfull with qcow2 on top of cephfs)

----- Mail original -----
De: "Lindsay Mathieson" <lindsay.mathieson at gmail.com>
À: "proxmoxve" <pve-user at pve.proxmox.com>
Envoyé: Mercredi 25 Mars 2015 11:56:36
Objet: [PVE-User] Problem Cloning Disk

Getting this error ever time I try to clone a VM or move its disk 

Src Disk is a ceph rbd image. I've tried using ceph rbd as the dest with the same error. 

c reate full clone of drive virtio0 (ceph1:vm-201-disk-1) 

'/mnt/cephfs/images/201/vm-201-disk-1.qcow2', fmt=qcow2 

size=136365211648 encryption=off cluster_size=65536 

preallocation='metadata' lazy_refcounts=off 
transferred: 0 bytes remaining: 136365211648 bytes total: 136365211648 bytes progression: 0.00 % 
qemu-img: output file is smaller than input file 

ERROR: storage migration failed: copy failed: command 

'/usr/bin/qemu-img convert -t writeback -p -n -f raw -O qcow2 


/mnt/cephfs/images/201/vm-201-disk-1.qcow2' failed: exit code 1 

pve-user mailing list 
pve-user at pve.proxmox.com 

More information about the pve-user mailing list