[PVE-User] Cisco ironport appliances on proxmox 8.1 not booting after upgrade (solved, FYI)

Jan Vlach janus at volny.cz
Wed Feb 14 16:15:23 CET 2024

Hi proxmox user list, 

we're running Cisco Ironport antispam appliances versions 14.x (FreeBSD11-based) and 15.x (FreeBSD13-based) on multiple proxmox clusters. 
In previous weeks, I've upgraded to latest 8.1.4, live migrated machines around. This worked flawlessly this time between 6.2.x and 6.5.x kernel. 

Today colleague needed to bump up RAM from 8G to 16G on an appliance and after shutdown and fresh start, appliance wouldn't come up with various errors - detecting raid device that's not there, missing python files, not bringing up networking. 
Same behavior was observed on old 14.x appliance, just shutdown and boot. No other changes.

After some digging around and reading changelog for qemu 8.1, the only real change logged for x86 is "Default to SMBIOS 3.0 information". 
Turns out this means that now default SMBIOS record size is 64bits vs 32bits and this causes problems.

Changing Hardware version for q35 to 8.0 from "latest" makse the appliance boot correctly, have networking, but even though UUID stays the same, the appliance generates new serial and games with cisco licensing ensue. Trying to use HW version 7.2 from time of installation doesn't help with keeping serials either.

Seems like FreeBSD can read 64bit SMBIOS entries since version 14.

Just a heads up so the next guy doesn't need to jump in head first and can prepare a bit.

https://wiki.qemu.org/ChangeLog/8.1 <https://wiki.qemu.org/ChangeLog/8.1>
https://forum.proxmox.com/threads/uuid-lost-after-changing-machine-type.136942/ <https://forum.proxmox.com/threads/uuid-lost-after-changing-machine-type.136942/>

More information about the pve-user mailing list