[PVE-User] Unable to boot VM - boot stuck up

Gianni Milo gianni.milo22 at gmail.com
Wed Apr 17 23:12:43 CEST 2019


- I booted from ISO and tried to reinstall / fix Grub - doesnt worked

Guess you mean you chrooted into the guest os and you executed
'grub-install /dev/sda' or something similar. Assuming that disk has a MBR
layout of course, did you also check if the boot partition was active? What
error did Grub returned (if any).

- I tried to verify the bootable flags on the VM disk / partition

Guess here you are talking about checking the active partition (or perhaps
guest os boot order on pve?).

- I tried to change VM HW options (CPU, memory, HDD, network) - max.
> simplifie its configuration - doesnt worked

Changing hw options in terms of hdd (virtio,scsi,ide etc), would not help
considering that the VM was able to boot properly before.

- I tried to restore VM from backup (restore from proxmox GUI) - same
> problem - restored VM wont boot

A full restore should be able to bring back all data, including the MBR
information needed in the early stages of the legacy boot process. Since
that did not happen, then it could mean the even the backup had this
critical information missing for some reason?

- and I dont know what else I tried to... I was under very heavy time
> pressure because of client....

Stress is also a factor which can lead to bad decisions, we all have been
there at some point... :)

Nothing worked! I still got message "Booting from hard disk".

My opinion is that system could not read MBR from the vdisk for some
reason. As you confirmed that the data and /boot was there via the recovery
cd, then can't think of anything else...Grub also failed to write on MBR?

So, I copied a VM template from another server to this node. started it up
> and voila... VM booted successfuly.

This is an indication that something was wrong with the vdisk of the
original VM (corruption?).
Did you also try to create a new blank VM, without a vdisk, and attach the
original vdisk to it?

So guys, my question is... have you ever faced up with this kind of
> problem? What shall be causing a problem and how to correctly and FAST to
> solve it? My VM size was 250GB, so every try takes soooo long, which ment,
> very long downtime...

Best thing would be to find the root cause of the problem of course (as it
may come back). Haven't faced this specific issue personally, but the
fastest recovery option I can think of, is by using ZFS as storage backend
and leverage by its fast snapshot/rollback capabilities. This is true
assuming that the corruption was not there for a long time, going
undetected...By the way, you didn't mention what storage backend you are
Another option would have been to add a small vdisk to the original VM,
partition it and copy /boot content from the original disk, install Grub on
its MBR and finally set the VM boot order to boot from this disk, instead
of the original disk.Of course modify fstab accordingly...This would prove
if the boot issue was on the original disk or not.


More information about the pve-user mailing list