[PVE-User] Unable to boot VM - boot stuck up

Branislav Viest info at branoviest.com
Wed Apr 17 20:05:08 CEST 2019

Hello guys, 

today I experienced a very strange problem. We had to reboot Proxmox node. On this node is just once Qemu VM, but after node reboot this VM was unable to boot. The boot process stuck up on the "Booting from hard disk". I tried probably all to solve this... 

- I booted from ISO and tried to reinstall / fix Grub - doesnt worked 
- I tried to verify the bootable flags on the VM disk / partition 
- I tried to change VM HW options (CPU, memory, HDD, network) - max. simplifie its configuration - doesnt worked 
- I tried to restore VM from backup (restore from proxmox GUI) - same problem - restored VM wont boot 
- I checked all logs - syslog, kernel, dmesg, nothing out there. 
- I tried to start VM manually from CLI 
- I tried to another HW reboot 
- and I dont know what else I tried to... I was under very heavy time pressure because of client.... 

Nothing worked! I still got message "Booting from hard disk". 

So, I copied a VM template from another server to this node. started it up and voila... VM booted successfuly. So, I resized the disk of this template created VM, mount them on proxmox host and copied data from non-booting VM to them (I copied all the data excluded the /boot - grub and kernel) and after that I was sucessfuly able to boot the VM. 

So guys, my question is... have you ever faced up with this kind of problem? What shall be causing a problem and how to correctly and FAST to solve it? My VM size was 250GB, so every try takes soooo long, which ment, very long downtime... 

On the VM is / was Debian Linux (Stretch stable) with Grub boot loader. PVE version: pve-manager/5.4-4/97a96833 (running kernel: 4.15.18-13-pve) 

Thank you 

S přátelským pozdravem / Best Regards 

Branislav Viest 

More information about the pve-user mailing list