[PVE-User] Migration VM from VMWare 5 (.vmdk) to Proxmox

Edgardo Ghibaudo edgardo.ghibaudo at provincia.biella.it
Thu Mar 31 09:51:09 CEST 2016

The Linux guest (RHEL 4) in VMware 5 has the following configuration:
     - SCSI controller 0    LSI Logical Parallel
I tried in Proxmox to use all the possible disk emulation (VIRTIO, IDE, 
SATA, SCSI), but the result is always the same (kernel panic !!).
I tried to start with Knoppix and I tried to update fstab, but the 
result is always the same (kernel panic !!).


Il 30/03/2016 16:47, Alessandro Briosi ha scritto:
> Il 30/03/2016 11:42, Edgardo Ghibaudo ha scritto:
>> I solved the previous problem.
>> Now the Linux guest (RHEL 4) in Proxmox environment starts, but after 
>> a while the VM panics reporting the following message:
>>    /mount: error 6 mounting ext3//
>>    //mount: error 2 mounting none//
>>    //switchroot: mount failed: 22//
>>    //umount /initrd/dev failed: 2//
>>    //kernel panic - not syncing//
>>    //Attempted to kill init !/
> The root device probably changed.
> You'll need to start in rescue mode with a CD and update fstab, 
> modules.conf, initrd (if needed) with mkinitd afterwards, and probably 
> grub.
> Or loop mount the disk image and fix it directly (though probably more 
> complicated)
> Or try to use the correct disk emulation. (sata, scsi, etc) in the 
> configuration.
> That basically depends on which one was used.
> Alessandro
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user

More information about the pve-user mailing list