[PVE-User] Open vSwitch and Clustering

Adam Thompson athompso at athompso.net
Sat Jan 17 19:21:10 CET 2015

No, I meant I had to completely rebuild my cluster from scratch :-(.

On January 17, 2015 11:24:29 AM CST, Brian Hart <brianhart at ou.edu> wrote:
>Adam --
>Thank you for the response.  I even tried backing out open vswitch
>completely - purging it from the system - and then manually
>reconfiguring a
>single NIC without even a bridge and could not restore the multicast
>communication.  However, I reinstalled the single node I tried setting
>OVS on, deleted it from the existing cluster configuration on the other
>system (which wasn't reloaded), and re-added it and its working again.
>Nothing has changed on the switch or the other node.  It seems for some
>reason as soon as I installed OVS it broke multicast for that node
>completely and the only way I could restore it was to reinstall.
>It sounds like my experience is worse than yours though?  In your case
>still have OVS installed and it is still working?
>On Fri, Jan 16, 2015 at 5:08 PM, Adam Thompson <athompso at athompso.net>
>> When running cluster communications through an ovs virtual interface,
>> encountered repeated communications problems.
>> Not 100% sure OVS was to blame, but since rebuilding and putting
>> communications on a dedicated NIC I haven't had any problems.
>> -Adam
>> On January 16, 2015 4:54:18 PM CST, Brian Hart <brianhart at ou.edu>
>>> We got two new systems that we installed the latest version of
>>> on.  Did an apt-get update and dist-upgrade to make sure they were
>on the
>>> most recent versions.  We then created a cluster and got them
>talking and
>>> all that went fine.
>>> The problem came when we added OVS to one of the nodes and set it
>all up
>>> in the GUI.  Once we did a reboot we have not been able to get the
>>> communications to work since then.  We have tried to revert it back
>>> completely - removing open vswitch packages and all and doing a
>>> config in the /etc/network/interfaces file but we cannot get
>multicast to
>>> work now between the two nodes.  Nothing else changed.
>>> Has anybody else run across this or are there known issues with
>doing OVS
>>> and clustering?  I've done a lot of google searching but have not
>found a
>>> clear answer or solution to a problem like this.
>>> Any help or advice is greatly appreciated!
>>> Thanks,
>>> Brian
>>> ------------------------------
>>> pve-user mailing list
>>> pve-user at pve.proxmox.com
>>> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>> --
>> Sent from my Android device with K-9 Mail. Please excuse my brevity.

Sent from my Android device with K-9 Mail. Please excuse my brevity.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.proxmox.com/pipermail/pve-user/attachments/20150117/765b9f80/attachment.htm>

More information about the pve-user mailing list