[PVE-User] Proxmox NFS issue

Muhammad Yousuf Khan sirtcp at gmail.com
Wed Nov 6 16:05:13 CET 2013

i am facing slow read and write on our new NAS.
here is the hardware detail.

Proxmox :
Xeon 3.2 (2 processors)
500GB HD for Proxmox and Debian OS.

Remote SAN/NAS:
OS : omniOS
RAM : 12 GB
Sharing protocol : NFS
Xeon 3.2 (2 processors)
3 Mix capasity HD 800GB,500GB and 1TB all are 64bit Cache.
ZFS RAID Type  : RaidZ

when i am inside the VM and trying to copy "to" network or "from" network i
see very slow traffic. specifically talking about inside VM.

kindly find an attach file. to see my read and write performance.
in side graphs Red line is showing my copy data-to-VM and white line
showing copy data-to-network.

when i am copying data from terminal it is showing me good speed.

here is the some more detail on Mount points. (output of my "df -h" command)

10.x.x.25:/tank/VMbase                       903G  2.1G  901G   1% /nfscom

here is some copy test on terminal from the nfs mount point

root at bull:/nfscom/images/1009# rsync --progress vm-1009-disk-1.raw /
   824311808   7%   70.00MB/s    0:02:18

(you can see i am coping 10GB file from NFS mount to "/" this is the same
VM image which is showing problem in the attached graphics)

now copying same VM from "/" to same NFS mount point.

root at bull:/nfscom/images# rsync --progress /vm-1009-disk-1.raw
   607682560   5%   63.71MB/s    0:02:35

you can see my read and writes are working-great from the console but when
it come to VM i am facing issues inside VM.

actually i have asked this question few weeks ago. some one suggested me in
the forum to buy a SSD for ZIL so it took me a while and i bought even two
SSDs 1 for Level 2 Arch and 1 for ZIL. but still i am standing at the same

Can anyone please tell me what mistake i am doing here.

even i tried FreeNas with same ZFS config i am facing same issue.

however when using Same NFS with Virtualbox in ubuntu 12.x it is doing

i tried any available HD type and all the modes available in proxmox, such
as "no cache" "sync" write through" on both raw and qemu drive types but
nothing help.

i dont know where i am doing wrong.

please help me out. i am very near to bang my head :).
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.proxmox.com/pipermail/pve-user/attachments/20131106/1ebc35e5/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: readwriteissue.JPG
Type: image/jpeg
Size: 75144 bytes
Desc: not available
URL: <http://lists.proxmox.com/pipermail/pve-user/attachments/20131106/1ebc35e5/attachment.jpe>

More information about the pve-user mailing list