[PVE-User] Several issues with gluster as storage.

Angel Docampo adocampo at dltec.net
Wed Dec 11 15:13:05 CET 2013

Hi there,

I'm having several problems with using gluster as a storage. I'm using a gluster replica 2 between two buildings, the connection is 10Gb.
I can access gluster and write so far so good. But when using proxmox the problems arise...

I cannot upload iso files (I think I've readed on the forum that its a bug) and in fact it's a minor issue.

The problem comes when I want to create a VM. It takes a long time (I guess depending the hard disk size) and if I try to access via ssh when it is trying to create the VM, when I cd to the glusterfs mountpoint it seems to be stalled (I cannot do a double-tab for autocomplete the name, for instance).
After a while, the GUI shows,
TASK ERROR: create failed - unable to create image: got lock timeout - aborting command

I can create the VM on a local storage (I didn't try a NFS share, iSCSI or another network destination) flawlessly, and then move the disk to the gluster storage without problems.
I can even mount via FUSE the gluster and the I CAN create the VM on it (but it is considered then a local storage and I cannot do a live migration, etc).

So, there is any problem with replicas? I tried on a distributed-only gluster on the lab and it worked perfect, but on my client's house I'm facing this...

Any idea?

I can post any log if you want, but I would also know your experience with this scenario. I have quite experience with gluster, so I'm pretty sure that this gluster is working as it should.

Thank you everyone,

Angel Docampo
Datalab Tecnologia, s.a.
Castillejos, 352 - 08025 Barcelona
Tel. 93.476.69.10 - 6711

Nota Legal<http://www.dltec.net/notalegal.html>

More information about the pve-user mailing list