[pve-devel] [PATCH v2 container 3/4] lxc: Add `link-down` config to allow setting interfaces as disconnected

Wolfgang Bumiller w.bumiller at proxmox.com
Mon Feb 20 13:33:06 CET 2023

On Mon, Feb 20, 2023 at 12:51:55PM +0100, Christoph Heiss wrote:
> On Fri, Feb 17, 2023 at 05:38:57PM +0100, Thomas Lamprecht wrote:
> > Am 17/02/2023 um 15:51 schrieb Wolfgang Bumiller:
> > >>  * Rename option to kebap-case
> > > Sorry I missed that when Thomas replied to the v1.
> > > This is a case where the property already exists in the VM api, so
> > > better reuse the snake_case version here. @Thomas?
> > >
> >
> > I assumed that, that's why I asked if keeping it that way would help to reuse some
> > code infra; not sure about how useful it is to keep it for API consumers to keep it
> > the same as in a quite different API end point,
> There really is no code-reuse between those two endpoints, so it made
> sense to me too to rename it.

It's more about possible code reuse in front-ends rather than in the
backend though, where a set of common options with common code to
fill/read/... them can definitely be a thing ;-)

> > but I see where you come from and don't
> > insist for going with snake-case, so if you think using the same style here has benefits.
> > we can ignore the guidance that new params should always use kebab-case.
> .. but I will rename it back to snake_case for v3, since that seems to
> be consensus here?

Given Thomas' plan to rename stuff in the future, I'd say yes, for now.

More information about the pve-devel mailing list