[pve-devel] [PATCH pve-kernel] fix #3781: add Provides: wireguard-modules to control.in

Thomas Lamprecht t.lamprecht at proxmox.com
Fri Dec 10 18:27:39 CET 2021


On 10.12.21 17:49, Stoiko Ivanov wrote:
> without this line `apt install wireguard` pulls in Debian's kernel +
> firmware which confilcts with pve-firmware - forcing users to install
> via `apt install --no-install-recommends wireguard-tools` in order
> to get the userspace utils.
> 
> For Debian's upstream kernel the linux-image-amd64 provides the
> modules [0] - since pve-kernel- at KVNAME@ already provides linux-image
> this should be the place where we add the provides
> 
> versioned dependency added since wireguard has a versioned dependency
> on wireguard-modules.
> 
> [0] https://salsa.debian.org/kernel-team/linux/-/blob/master/debian/templates/control.image.meta.in

did we actually had users run into this? I'm probably way to accustomed to
just installing `wireguard-tools` that I never even noticed that there's a
meta package - I mean wireguard got mainlined with 5.6, that was released on
2020-01-26, so rather ancient ;-P

anyhow, lgtm




More information about the pve-devel mailing list