[pve-devel] [PATCH v2 common 04/13] PBSClient: adapt error message to include full package names

Stefan Reiter s.reiter at proxmox.com
Thu Apr 22 17:34:48 CEST 2021


More helpful for a user to know what they're missing.

Suggested-by: Dominic Jäger <d.jaeger at proxmox.com>
Signed-off-by: Stefan Reiter <s.reiter at proxmox.com>
---

new in v2

 src/PVE/PBSClient.pm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/PVE/PBSClient.pm b/src/PVE/PBSClient.pm
index 857cff0..16f7765 100644
--- a/src/PVE/PBSClient.pm
+++ b/src/PVE/PBSClient.pm
@@ -141,7 +141,7 @@ my sub do_raw_client_cmd {
 
     my $client_exe = (delete $opts{binary}) || 'proxmox-backup-client';
     $client_exe = "/usr/bin/$client_exe";
-    die "executable not found '$client_exe'! Proxmox backup client or file restore not installed?\n"
+    die "executable not found '$client_exe'! proxmox-backup-client or proxmox-backup-file-restore not installed?\n"
 	if ! -x $client_exe;
 
     my $scfg = $self->{scfg};
-- 
2.20.1





More information about the pve-devel mailing list