[pve-devel] [PATCH manager 2/2] ui: fix HotplugFeatureSelector

Dominik Csapak d.csapak at proxmox.com
Fri May 29 13:07:57 CEST 2020


we recently changed the setValue behaviour of the inputpanel and editwindow
(we now set all fields with the same names), which leads to wrong
behaviour here

use a different name for the internal checkboxes to avoid this

Signed-off-by: Dominik Csapak <d.csapak at proxmox.com>
---
 www/manager6/form/HotplugFeatureSelector.js | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/www/manager6/form/HotplugFeatureSelector.js b/www/manager6/form/HotplugFeatureSelector.js
index 3bf394bc..a79fb845 100644
--- a/www/manager6/form/HotplugFeatureSelector.js
+++ b/www/manager6/form/HotplugFeatureSelector.js
@@ -6,7 +6,7 @@ Ext.define('PVE.form.HotplugFeatureSelector', {
     vertical: true,
 
     defaults: {
-	name: 'hotplug',
+	name: 'hotplugCbGroup',
 	submitValue: false
     },
     items: [
@@ -43,7 +43,7 @@ Ext.define('PVE.form.HotplugFeatureSelector', {
 	} else if (value !== '0') {
 	    newVal = value.split(',');
 	}
-	me.callParent([{ hotplug: newVal }]);
+	me.callParent([{ hotplugCbGroup: newVal }]);
     },
 
     // override framework function to
-- 
2.20.1





More information about the pve-devel mailing list