[pve-devel] applied: [RFC manager] add help button to 'My Settings' window
Thomas Lamprecht
t.lamprecht at proxmox.com
Tue Nov 13 15:19:35 CET 2018
On 11/13/18 1:48 PM, David Limbeck wrote:
> link to 'gui_my_settings' in docs
applied, regarding your RFC questions:
> RFC for following reasons:
> 1. unsure about wording
seems like a good start, can be improved later.
> 2. better name for [[gui_my_settings]]?
it follows our generally used schema, i.e., chaper base name + heading (if at
heading boundary) so OK for me.
> 3. thumbnail out of date
we have tooling for this, and someone (probably Dietmar) will update them
before the next point release.
> 4. anything missing?
it's a good start and has value, IMO, so I applied it as is for now.
>
> Signed-off-by: David Limbeck <d.limbeck at proxmox.com>
> ---
> www/manager6/window/Settings.js | 19 +++++++++++++------
> 1 file changed, 13 insertions(+), 6 deletions(-)
>
> diff --git a/www/manager6/window/Settings.js b/www/manager6/window/Settings.js
> index ef9dc021..1a4d8599 100644
> --- a/www/manager6/window/Settings.js
> +++ b/www/manager6/window/Settings.js
> @@ -8,12 +8,20 @@ Ext.define('PVE.window.Settings', {
> bodyPadding: 10,
> resizable: false,
>
> - buttons: [{
> - text: gettext('Close'),
> - handler: function() {
> - this.up('window').close();
> + buttons: [
> + {
> + xtype: 'proxmoxHelpButton',
> + onlineHelp: 'gui_my_settings',
> + hidden: false
> + },
> + '->',
> + {
> + text: gettext('Close'),
> + handler: function() {
> + this.up('window').close();
> + }
> }
> - }],
> + ],
>
> layout: {
> type: 'hbox',
> @@ -317,6 +325,5 @@ Ext.define('PVE.window.Settings', {
> onShow: function() {
> var me = this;
> me.callParent();
> -
> }
> });
>
More information about the pve-devel
mailing list