[pve-devel] Long standing bug in "override_for_missing_acs_capabilities.patch"

Daniel Boothby daniel.boothby at gmail.com
Wed Apr 18 11:50:10 CEST 2018


Apologies, I have indeed misunderstood it as I didn't realise it took into
account the previous chunk alterations.

Is there any way to know which version of the ACS patch is used in the
current 5.1-3 ISO download of Proxmox? My system needs one of the newest
ACS patch versions to override the IOMMU groups correctly and 5.1-3 doesn't
appear to include it. I successfully built from source a month or so back
(manually correcting a different ACS patch issue that appears to have since
been corrected), but am hopeful I can move back to the normal releases soon.

On 18 April 2018 at 10:14, Dominik Csapak <d.csapak at proxmox.com> wrote:

> On 04/18/2018 11:12 AM, Daniel Boothby wrote:
>
>> This issue is still there but now on line 188:
>>
>> @@ -4529,6 +4630,7 @@ static const struct pci_dev_acs_enabled {
>>
>> should instead be:
>>
>> @@ -4529,6 +4529,7 @@ static const struct pci_dev_acs_enabled {
>>
>>
> i think you misunderstand this patch syntax
>
> it says
>
> it was at line 4529 column 6
> now it is at line 4630 column 7
>
> which is correct as the patch add about 100 lines at the beginning...
>
>
> _______________________________________________
> pve-devel mailing list
> pve-devel at pve.proxmox.com
> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel
>


More information about the pve-devel mailing list