[pve-devel] VM in HA not start

Gilberto Nunes gilberto.nunes32 at gmail.com
Mon Sep 21 14:19:30 CEST 2015


UPDATE:

When I try start the VM on node 2, here is the error:

proxmox02:~# qm start 101
ipcc_send_rec failed: File too large
Executing HA start for VM 101
ipcc_send_rec failed: File too large



2015-09-21 9:18 GMT-03:00 Gilberto Nunes <gilberto.nunes32 at gmail.com>:

> Hi...
>
> I deploy here three servers, with PVE 4 and put a VM in HA.
> When I pull off the power supply on server 1, the VM was unable to start
> on server 2...
> Here's the output:
>
> Sep 21 09:14:55 proxmox02 pve-ha-lrm[6328]: <root at pam> starting task
> UPID:proxmox02:000018B9:0008B1EE:55FFF4BF:qmstart:101:root at pam:
> Sep 21 09:14:55 proxmox02 pve-ha-lrm[6329]: start VM 101:
> UPID:proxmox02:000018B9:0008B1EE:55FFF4BF:qmstart:101:root at pam:
> Sep 21 09:14:55 proxmox02 kernel: [ 5697.041254] device tap101i0 entered
> promiscuous mode
> Sep 21 09:14:55 proxmox02 kernel: [ 5697.045101] vmbr0: port 2(tap101i0)
> entered forwarding state
> Sep 21 09:14:55 proxmox02 kernel: [ 5697.045107] vmbr0: port 2(tap101i0)
> entered forwarding state
> Sep 21 09:14:55 proxmox02 kernel: [ 5697.050579] drbd vm-101-disk-1: State
> change failed: Need access to UpToDate data
> Sep 21 09:14:55 proxmox02 kernel: [ 5697.050711] drbd vm-101-disk-1:
> Failed: role( Secondary -> Primary )
> Sep 21 09:14:55 proxmox02 kernel: [ 5697.050714] drbd vm-101-disk-1:
> Auto-promote failed: Need access to UpToDate data
> Sep 21 09:14:55 proxmox02 kernel: [ 5697.128290] vmbr0: port 2(tap101i0)
> entered disabled state
> Sep 21 09:14:55 proxmox02 pve-ha-lrm[6329]: start failed: command
> '/usr/bin/systemd-run --scope --slice qemu --unit 101 -p 'CPUShares=1000'
> /usr/bin/
> kvm -id 101 -chardev
> 'socket,id=qmp,path=/var/run/qemu-server/101.qmp,server,nowait' -mon
> 'chardev=qmp,mode=control' -vnc unix:/var/run/qemu-server/1
> 01.vnc,x509,password -pidfile /var/run/qemu-server/101.pid -daemonize
> -smbios 'type=1,uuid=1cd8d23c-369b-49c9-b957-ac64037e9888' -name ZimbraMail
> -sm
> p '1,sockets=1,cores=1,maxcpus=1' -nodefaults -boot
> 'menu=on,strict=on,reboot-timeout=1000' -vga vmware -cpu
> SandyBridge,+kvm_pv_unhalt,+kvm_pv_eoi,e
> nforce -m 8192 -k pt-br -device
> 'pci-bridge,id=pci.2,chassis_nr=2,bus=pci.0,addr=0x1f' -device
> 'pci-bridge,id=pci.1,chassis_nr=1,bus=pci.0,addr=0x1e'
> -device 'piix3-usb-uhci,id=uhci,bus=pci.0,addr=0x1.0x2' -device
> 'usb-tablet,id=tablet,bus=uhci.0,port=1' -device
> 'virtio-balloon-pci,id=balloon0,bus
> =pci.0,addr=0x3' -iscsi
> 'initiator-name=iqn.1993-08.org.debian:01:c46de021e42d' -drive
> 'file=/dev/drbd/by-res/vm-101-disk-1/0,if=none,id=drive-virtio
> 0,cache=writethrough,format=raw,aio=threads,detect-zeroes=on' -device
> 'virtio-blk-pci,drive=drive-virtio0,id=virtio0,bus=pci.0,addr=0xa,bootindex=100
> ' -netdev
> 'type=tap,id=net0,ifname=tap101i0,script=/var/lib/qemu-server/pve-bridge,downscript=/var/lib/qemu-server/pve-bridgedown,vhost=on'
> -device '
> virtio-net-pci,mac=BE:91:A2:7F:05:B7,netdev=net0,bus=pci.0,addr=0x12,id=net0,bootindex=300''
> failed: exit code 1
> Sep 21 09:14:55 proxmox02 pve-ha-lrm[6328]: <root at pam> end task
> UPID:proxmox02:000018B9:0008B1EE:55FFF4BF:qmstart:101:root at pam: start
> failed: command
> '/usr/bin/systemd-run --scope --slice qemu --unit 101 -p 'CPUShares=1000'
> /usr/bin/kvm -id 101 -chardev 'socket,id=qmp,path=/var/run/qemu-server/101
> .qmp,server,nowait' -mon 'chardev=qmp,mode=control' -vnc
> unix:/var/run/qemu-server/101.vnc,x509,password -pidfile
> /var/run/qemu-server/101.pid -daemo
> nize -smbios 'type=1,uuid=1cd8d23c-369b-49c9-b957-ac64037e9888' -name
> ZimbraMail -smp '1,sockets=1,cores=1,maxcpus=1' -nodefaults -boot
> 'menu=on,stri
> ct=on,reboot-timeout=1000' -vga vmware -cpu
> SandyBridge,+kvm_pv_unhalt,+kvm_pv_eoi,enforce -m 8192 -k pt-br -device
> 'pci-bridge,id=pci.2,chassis_nr=2
> ,bus=pci.0,addr=0x1f' -device
> 'pci-bridge,id=pci.1,chassis_nr=1,bus=pci.0,addr=0x1e' -device
> 'piix3-usb-uhci,id=uhci,bus=pci.0,addr=0x1.0x2' -device
> 'usb-tablet,id=tablet,bus=uhci.0,port=1' -device
> 'virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3' -iscsi
> 'initiator-name=iqn.1993-08.org.debian:01
> :c46de021e42d' -drive
> 'file=/dev/drbd/by-res/vm-101-disk-1/0,if=none,id=drive-virtio0,cache=writethrough,format=raw,aio=threads,detect-zeroes=on'
> -de
> vice
> 'virtio-blk-pci,drive=drive-virtio0,id=virtio0,bus=pci.0,addr=0xa,bootindex=100'
> -netdev 'type=tap,id=net0,ifname=tap101i0,script=/var/lib/qemu-
> server/pve-bridge,downscript=/var/lib/qemu-server/pve-bridgedown,vhost=on'
> -device 'virtio-net-pci,mac=BE:91:A2:7F:05:B7,netdev=net0,bus=pci.0,addr=0
> x12,id=net0,bootindex=300'' failed: exit code 1
> Sep 21 09:14:55 proxmox02 pve-ha-lrm[6328]: unable to start service vm:101
> ^C
>
> Somebody can help me???
>
> --
>
> Gilberto Ferreira
> +55 (47) 9676-7530
> Skype: gilberto.nunes36
>
>


-- 

Gilberto Ferreira
+55 (47) 9676-7530
Skype: gilberto.nunes36
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pve.proxmox.com/pipermail/pve-devel/attachments/20150921/f6151a52/attachment-0001.html>


More information about the pve-devel mailing list