[pve-devel] [PATCH] pve-bridge : use mtu of the bridge for tap interface

Dietmar Maurer dietmar at proxmox.com
Fri Sep 28 16:20:00 CEST 2012


applied, thanks.

> -----Original Message-----
> From: pve-devel-bounces at pve.proxmox.com [mailto:pve-devel-
> bounces at pve.proxmox.com] On Behalf Of Alexandre Derumier
> Sent: Freitag, 28. September 2012 10:58
> To: pve-devel at pve.proxmox.com
> Subject: [pve-devel] [PATCH] pve-bridge : use mtu of the bridge for tap
> interface
> 
> currently if the bridge have a mtu of 9000, when putting a tap interface on it
> (mtu 1500 by default), the mtu of the bridge goes to 1500.
> 
> we want that the mtu of the tap interface equal the mtu of the bridge
> 
> correcting bug:
> https://bugzilla.proxmox.com/show_bug.cgi?id=258
> 
> Signed-off-by: Alexandre Derumier <aderumier at odiso.com>
> ---
>  pve-bridge |    4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/pve-bridge b/pve-bridge
> index 2054705..f63be85 100755
> --- a/pve-bridge
> +++ b/pve-bridge
> @@ -28,7 +28,9 @@ die "unable to parse network config '$netid'\n" if !$net;
> my $bridge = $net->{bridge};  die "unable to get bridge setting\n" if !$bridge;
> 
> -system ("/sbin/ifconfig $iface 0.0.0.0 promisc up") == 0 ||
> +my $bridgemtu =
> +PVE::Tools::file_read_firstline("/sys/class/net/$bridge/mtu");
> +
> +system ("/sbin/ifconfig $iface 0.0.0.0 promisc up mtu $bridgemtu") == 0
> +||
>      die "interface activation failed\n";
> 
>  if ($net->{rate}) {
> --
> 1.7.10
> 
> _______________________________________________
> pve-devel mailing list
> pve-devel at pve.proxmox.com
> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel




More information about the pve-devel mailing list