[pve-devel] make error in pve-cluster/trunk

Seth Lauzon seth.lauzon at gmail.com
Fri Jun 24 21:54:12 CEST 2011


Dietmar,

Thanks for your help.  One thing I have noticed is that although it no longer throws errors when running make it does not install Cluster.pm to /usr/share/perl5/ as it says it does.  To move on through the installation process I still had to run 'make install-data-am' in the pve-cluster/build/perl directory.

Thanks,
Seth


On Jun 24, 2011, at 1:09 PM, Dietmar Maurer wrote:

> fixed - please try again.
> 
>> -----Original Message-----
>> From: Seth Lauzon [mailto:seth.lauzon at gmail.com]
>> Sent: Freitag, 24. Juni 2011 19:38
>> To: Dietmar Maurer
>> Cc: pve-devel at pve.proxmox.com
>> Subject: Re: [pve-devel] make error in pve-cluster/trunk
>> 
>> At revision 6167.
>> 
>> Same Error.
>> 
>> 
>> On Jun 24, 2011, at 12:31 PM, Dietmar Maurer wrote:
>> 
>>> This also looks like you are not using the latest sources. Try
>>> 
>>> # svn update
>>> 
>>> Does that help?
>>> 
>>> - Dietmar
>>> 
>>>> -----Original Message-----
>>>> From: pve-devel-bounces at pve.proxmox.com [mailto:pve-devel-
>>>> bounces at pve.proxmox.com] On Behalf Of Seth Lauzon
>>>> Sent: Freitag, 24. Juni 2011 19:21
>>>> To: pve-devel at pve.proxmox.com
>>>> Subject: [pve-devel] make error in pve-cluster/trunk
>>>> 
>>>> make[2]: Entering directory `/usr/local/src/pve/pve-cluster/trunk/build'
>>>> Making install in src
>>>> make[3]: Entering directory `/usr/local/src/pve/pve-cluster/trunk/build/src'
>>>> make[4]: Entering directory `/usr/local/src/pve/pve-cluster/trunk/build/src'
>>>> test -z "/usr/bin" || /bin/mkdir -p "/usr/local/src/pve/pve-
>>>> cluster/trunk/build/debian/pve-cluster/usr/bin"
>>>> /usr/bin/install -c pmxcfs '/usr/local/src/pve/pve-
>>>> cluster/trunk/build/debian/pve-cluster/usr/bin'
>>>> make[4]: Nothing to be done for `install-data-am'.
>>>> make[4]: Leaving directory `/usr/local/src/pve/pve-cluster/trunk/build/src'
>>>> make[3]: Leaving directory `/usr/local/src/pve/pve-cluster/trunk/build/src'
>>>> Making install in perl
>>>> make[3]: Entering directory `/usr/local/src/pve/pve-cluster/trunk/build/perl'
>>>> make[4]: Entering directory `/usr/local/src/pve/pve-cluster/trunk/build/perl'
>>>> test -z "/usr/bin" || /bin/mkdir -p "/usr/local/src/pve/pve-
>>>> cluster/trunk/build/debian/pve-cluster/usr/bin"
>>>> /usr/bin/install -c pvecm pvecert '/usr/local/src/pve/pve-
>>>> cluster/trunk/build/debian/pve-cluster/usr/bin'
>>>> make  install-exec-hook
>>>> make[5]: Entering directory `/usr/local/src/pve/pve-cluster/trunk/build/perl'
>>>> perl -I. ./pvecm verifyapi
>>>> Can't locate PVE/Cluster.pm in @INC (@INC contains: . /etc/perl
>>>> /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1
>>>> /usr/lib/perl5
>>>> /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10
>>>> /usr/local/lib/site_perl .) at ./pvecm line 11.
>>>> BEGIN failed--compilation aborted at ./pvecm line 11.
>>>> make[5]: *** [install-exec-hook] Error 2
>>>> make[5]: Leaving directory `/usr/local/src/pve/pve-cluster/trunk/build/perl'
>>>> make[4]: *** [install-exec-am] Error 2
>>>> make[4]: Leaving directory `/usr/local/src/pve/pve-cluster/trunk/build/perl'
>>>> make[3]: *** [install-am] Error 2
>>>> make[3]: Leaving directory `/usr/local/src/pve/pve-cluster/trunk/build/perl'
>>>> make[2]: *** [install-recursive] Error 1
>>>> make[2]: Leaving directory `/usr/local/src/pve/pve-cluster/trunk/build'
>>>> dh_auto_install: make -j1 install DESTDIR=/usr/local/src/pve/pve-
>>>> cluster/trunk/build/debian/pve-cluster returned exit code 2
>>>> make[1]: *** [binary] Error 29
>>>> make[1]: Leaving directory `/usr/local/src/pve/pve-cluster/trunk/build'
>>>> dpkg-buildpackage: error: fakeroot debian/rules binary gave error
>>>> exit status 2
>>>> make: *** [pve-cluster_1.0-1_amd64.deb] Error 2
>>>> 
>>>> 
>>>> The culprit appears to be this line in pve-cluster/trunk/build/perl/:
>>>> 
>>>> install-am: all-am
>>>>       @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
>>>> 
>>>> The solution would be this statement:
>>>> 
>>>> install-am: all-am
>>>>       @$(MAKE) $(AM_MAKEFLAGS) install-data-am install-exec-am
>>>> 
>>>> I have attempted to modify Makfile.* in src/ and perl/, but once the
>>>> autoconf command is run in autogen.sh it overwrites my changes.
>>>> 
>>>> The workaround currently is:
>>>> 
>>>> make
>>>> cd build/perl/
>>>> make install-data-am
>>>> cd ../..
>>>> make
>>>> 
>>>> Thanks,
>>>> Seth
>>>> _______________________________________________
>>>> pve-devel mailing list
>>>> pve-devel at pve.proxmox.com
>>>> http://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel
>>> 
>>> 
>> 
> 
> 



More information about the pve-devel mailing list