[pve-devel] Error: unable to connect to socket

Oleg Kostyuk cub.uanic at gmail.com
Tue Dec 6 10:31:51 CET 2011


Hello,

I'm using Proxmox VE 2.0. It installed well, and I was able to create
new VM and run it. But when I'm trying to look at VM console, I see
error. As I found, it's because of some error with vncproxy. I tried
to run manually same command as I found in log, and got:

  # /bin/nc -l -p 5903 -w 10 -c /usr/sbin/qm vncproxy 100
  vncproxy: forward host lookup failed: Unknown host


I did small debug, and seems that's because of problem in /usr/sbin/qm:

    unable to connect to socket '/var/run/qemu-server/100.vnc' -
Connection refused at /usr/sbin/qm line 53.
     at /usr/share/perl5/PVE/RESTHandler.pm line 488
        PVE::RESTHandler::cli_handler('main', 'qm vncproxy',
'vncproxy', 'ARRAY(0x2287080)', 'ARRAY(0x40d44a8)', undef, undef)
called at /usr/share/perl5/PVE/CLIHandler.pm line 189
        PVE::CLIHandler::handle_cmd('HASH(0x40d5778)', 'qm',
'vncproxy', 'ARRAY(0x2287080)', undef, '/usr/sbin/qm') called at
/usr/sbin/qm line 452

How this can be solved?
Thanks in advance!

-- 
Sincerely yours,
Oleg Kostyuk (CUB-UANIC)


More information about the pve-devel mailing list