[yew-devel] [PATCH yew-comp] fix #6382: tasks: don't add duplicate tasks into the list
Dietmar Maurer
dietmar at proxmox.com
Mon May 12 10:31:41 CEST 2025
>
> - let start = self.start;
> - filter["start"] = start.into();
> + let start = match (self.fresh_load, self.store.read().last()) {
> + (false, Some(last)) => last.starttime,
> + _ => 0,
> + };
> + if start > 0 && filter["until"].as_i64().unwrap_or(i64::MAX) > start {
> + filter["until"] = start.into();
> + }
The naming is quite confusing - maybe rename "start" into "until"?
Also, value "0" is not used (just a marker), so maybe it is cleaner to use an option?
More information about the yew-devel
mailing list