<div dir="ltr">I have a 1TB RBD volume attached to a KVM virtual machine. Removing the volume from this machine was somewhat problematic.<div><br></div><div>While the machine is running:</div><div><br></div><div>I selected the disk and clicked Remove. This cause the disk to appear as 'unused0' which mapped to the Ceph RBD volume.</div>
<div><br></div><div>I then highlighted 'unused0' and clicked Remove again.</div><div><br></div><div>I got three errors:</div><div>One was a timeout error attempting to get flock the VM's lock file (/var/lock/qemu-server/lock-400.conf).</div>
<div>Another was a connection timeout error.</div><div>Another was an internal server error.</div><div><br></div><div>I was unable to find any logs specifying the exact nature of any of these errors. pvedaemon and pveproxy both simply logged the request.</div>
<div><br></div><div>I tried deleting the disk from Ceph directly which is when I discovered the watcher on the rbd_header object. I verified that it was the KVM process that held the lock on the RBD volume and shutdown the VM.</div>
<div><br></div><div>While the machine is not running:</div><div><br></div><div>After selecting the 'unused0' disk and clicking Remove the web interface froze for some time, and then finally came back with an Internal Server Error.</div>
<div><br></div><div>The volume was no longer present in the web interface, and I confirmed both that the volume was no longer listed in rbd -p volumes ls -- as well as inspecting attempting to inspect all of the objects that used to make up the volume (rbd.stat returned an exception saying that the file wasn't found--confirming the volume's completed deletion).</div>
<div><br></div><div>I am running PVE 3.1-24/060bd5a6 ¬†with the 2.6.32 kernel.</div><div><br></div><div>Is this a known issue? Has this been fixed in later versions of Proxmox? Should I file a new bug? Is there any additional information I should attempt to gather before filing?</div>
<div><br></div><div>Thanks!</div></div>