[PVE-User] Backup to PBS fails

Konold, Martin martin.konold at konsec.com
Tue Sep 7 17:48:10 CEST 2021


Hi Dietmar,

vm100 is a template.
vm102 is up and running but shows the same error.

root at hbase01 ~ # vzdump 102 --mode snapshot --node hbase01 --compress 
zstd --all 0 --storage PVE-FE --mailnotification always
INFO: starting new backup job: vzdump 102 --mode snapshot --compress 
zstd --storage PVE-FE --mailnotification always --all 0 --node hbase01
INFO: Starting Backup of VM 102 (qemu)
INFO: Backup started at 2021-09-07 17:47:03
INFO: status = running
INFO: VM Name: rtnl-102.h.konsec.com
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: skip unused drive 'pool01:vm-102-disk-1' (not included into 
backup)
INFO: creating Proxmox Backup Server archive 
'vm/102/2021-09-07T15:47:03Z'
INFO: issuing guest-agent 'fs-freeze' command
INFO: enabling encryption
INFO: issuing guest-agent 'fs-thaw' command
ERROR: VM 102 qmp command 'backup' failed - backup connect failed: 
command error: EACCES: Permission denied
INFO: aborting backup job
INFO: resuming VM again
ERROR: Backup of VM 102 failed - VM 102 qmp command 'backup' failed - 
backup connect failed: command error: EACCES: Permission denied
INFO: Failed at 2021-09-07 17:47:04
INFO: Backup job finished with errors
job errors

---
Regards
ppa. Martin Konold

--
Martin Konold - Prokurist, CTO
KONSEC GmbH -⁠ make things real
Amtsgericht Stuttgart, HRB 23690
Geschäftsführer: Andreas Mack
Im Köller 3, 70794 Filderstadt, Germany

Am 2021-09-07 17:22, schrieb Dietmar Maurer:
>> > Backup to a Proxmox Backup Server PBS fails though
>> root at hbase01 ~ # vzdump 100 --mode snapshot --node hbase01 --compress
>> zstd --all 0 --storage PVE-FE-3 --mailnotification always
>> INFO: starting new backup job: vzdump 100 --all 0 --node hbase01
>> --mailnotification always --storage PVE-FE-3 --mode snapshot 
>> --compress
>> zstd
>> INFO: Starting Backup of VM 100 (qemu)
>> INFO: Backup started at 2021-09-07 13:38:31
>> INFO: status = stopped
>> INFO: backup mode: stop
>> INFO: ionice priority: 7
>> INFO: VM Name: CentOS-8-100.h.konsec.com
>> INFO: include disk 'scsi0' 'pool01:base-100-disk-0' 10G
>> INFO: creating Proxmox Backup Server archive
>> 'vm/100/2021-09-07T11:38:31Z'
>> INFO: starting kvm to execute backup task
>> Use of uninitialized value in split at
>> /usr/share/perl5/PVE/QemuServer/Cloudinit.pm line 100.
>> /dev/rbd45
>> generating cloud-init ISO
>> ERROR: VM 100 qmp command 'backup' failed - backup connect failed:
>> command error: EACCES: Permission denied
> 
> This error is not related to backup. Seems the VM is stopped and does
> not have a correctly initialize cloud-init ISO.
> 
> Please can you try if it is possible to start this VM at all?



More information about the pve-user mailing list