[PVE-User] Windows sever 2016 vm with very high ram usage

Leandro Roggerone leandro at tecnetmza.com.ar
Mon Mar 29 15:37:59 CEST 2021


Hi guys , thanks for your words , have some feedback:

Maybe Proxmox cannot look inside the VM for the actual memory usage because
the VirtIO balloon driver is not installed or active? Or maybe the other
90% is in use as Windows file cache?
I think so ...
Dont know about windows file cache ...

Have you installed the VirtIO drivers for Windows? Are you assigning too
many vCPUs or memory? Can you share the VM configuration file? Can you tell
us something about your Proxmox hardware and version?
 No , I have not ... now you mentioned im reading about VirtIO , I will try
to install and let you know how it goes
 Should install it no my pve box or directly inside windows vm ?
I'm assigning max vCPUs abailables (24 , 4 sockets 6 cores) and 32gb for
memory.
(I really don't know about any criteria to assign vcpus)

This is VM config file:

root at pve:~# cat /etc/pve/nodes/pve/qemu-server/107.conf

bootdisk: ide0

cores: 6

ide0: local-lvm:vm-107-disk-0,size=150G

ide1: local-lvm:vm-107-disk-1,size=350G

ide2:
local:iso/Windows_Server_2016_Datacenter_EVAL_en-us_14393_refresh.ISO,media=cdrom,size=6808810K

memory: 32768

name: KAIKENII

net0: e1000=1A:F1:10:BF:92:0A,bridge=vmbr3,firewall=1

numa: 0

ostype: win10

scsihw: virtio-scsi-pci

smbios1: uuid=daf8f767-59c7-4e87-b3be-75d4a8020c38

sockets: 4

vmgenid: a7634624-1230-4a3e-9e7c-255d32ad2030

My PVE is:
CPU(s) 24 x Intel(R) Xeon(R) CPU X5680 @ 3.33GHz (2 Sockets)
Kernel Version Linux 5.0.15-1-pve #1 SMP PVE 5.0.15-1 (Wed, 03 Jul 2019
10:51:57 +0200)
PVE Manager Version pve-manager/6.0-4/2a719255
Total Mem = 64GB.

That's all.
Thanks




El vie, 26 mar 2021 a las 11:40, Arjen via pve-user (<
pve-user at lists.proxmox.com>) escribió:

>
>
>
> ---------- Forwarded message ----------
> From: Arjen <leesteken at protonmail.ch>
> To: Proxmox VE user list <pve-user at lists.proxmox.com>
> Cc:
> Bcc:
> Date: Fri, 26 Mar 2021 14:39:13 +0000
> Subject: Re: [PVE-User] Windows sever 2016 vm with very high ram usage
> On Friday, March 26th, 2021 at 15:28, Leandro Roggerone <
> leandro at tecnetmza.com.ar> wrote:
>
> > Hi guys , Just wanted to share this with you.
> >
>
> > After creating a VM for a windows sever 2016 with 32 GB ram I can
> >
>
> > see continuos high memory usage (about 99-100%).
> >
>
> > I have no running task , since it is a fresh server and from task manager
> >
>
> > can see a 10% of memory usage.
> >
>
> > Regarding those confusing differences, server performance is very bad.
>
> Maybe Proxmox cannot look inside the VM for the actual memory usage
> because the VirtIO balloon driver is not installed or active? Or maybe the
> other 90% is in use as Windows file cache?
>
> > User experience is very poor with a non fluent user interface.
> >
>
> > Is there something to do / check to improve this ?
>
> Have you installed the VirtIO drivers for Windows? Are you assigning too
> many vCPUs or memory? Can you share the VM configuration file? Can you tell
> us something about your Proxmox hardware and version?
>
> > Any advice would be welcome.
>
>
> Maybe search the forum for similar Windows performance questions?
>
>
> https://forum.proxmox.com/forums/proxmox-ve-installation-and-configuration.16/
>
> > Thanks.
>
> best of luck, Arjen
>
>
> ---------- Forwarded message ----------
> From: Arjen via pve-user <pve-user at lists.proxmox.com>
> To: Proxmox VE user list <pve-user at lists.proxmox.com>
> Cc: Arjen <leesteken at protonmail.ch>
> Bcc:
> Date: Fri, 26 Mar 2021 14:39:13 +0000
> Subject: Re: [PVE-User] Windows sever 2016 vm with very high ram usage
> _______________________________________________
> pve-user mailing list
> pve-user at lists.proxmox.com
> https://lists.proxmox.com/cgi-bin/mailman/listinfo/pve-user
>


More information about the pve-user mailing list