[PVE-User] mtu setting for virtual ethernet

Dominik Csapak d.csapak at proxmox.com
Tue Mar 23 13:29:08 CET 2021


On 3/23/21 13:03, Konold, Martin wrote:
> Hi Proxmox Users,
> 
> I learned from the Proxmox forum that appending mtu=1 to the network 
> definition of a virtual machine instructs the virtual ethernet device to 
> inherit the mtu from the corresponding bridge.
> 
> In my case
> 
> net0: virtio=FA:FF:FF:FF:FF:D8,bridge=vmbr15,mtu=1
> 
> and the bridge definition
> 
> iface vmbr15 inet static
>          address 10.21.15.11/24
>          bridge-ports enp35s0.4015
>          bridge-stp off
>          bridge-fd 0
>          bridge-vlan-aware yes
>          bridge-vids 2-4094
>          mtu 1400
> 
> According to my tests this seams to work indeed. The guest OS shows the 
> 1400 mtu.
> 
> Question 1: Can the mtu=1 (magic value for auto mtu inheritance) be made  > the default?

probably not because of backwards compatibility (live-migration etc.)
but maybe we could (should?) either add it as default for
new vms in the webui, or expose it as a gui field

would you mind opening a feature request? https://bugzilla.proxmox.com

> 
> Question 2: It seams that appending mtu=1 breaks the webUI. I get 
> "Unable to parse network options".

thanks for reporting, i sent a patch on the devel list to fix that

> 
> Kind Regards
> ppa. Martin Konold
> 
> -- 
> Martin Konold - Prokurist, CTO
> KONSEC GmbH -⁠ make things real
> Amtsgericht Stuttgart, HRB 23690
> Geschäftsführer: Andreas Mack
> Im Köller 3, 70794 Filderstadt, Germany
> 
> _______________________________________________
> pve-user mailing list
> pve-user at lists.proxmox.com
> https://lists.proxmox.com/cgi-bin/mailman/listinfo/pve-user





More information about the pve-user mailing list