[PVE-User] E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

Hongyi Zhao hongyi.zhao at gmail.com
Thu Jun 24 15:41:35 CEST 2021


On Thu, Jun 24, 2021 at 8:11 PM Faris Raouf via pve-user
<pve-user at lists.proxmox.com> wrote:
>
>
>
>
> ---------- Forwarded message ----------
> From: Faris Raouf <asterisk at raouf.net>
> To: "'Proxmox VE user list'" <pve-user at lists.proxmox.com>
> Cc:
> Bcc:
> Date: Thu, 24 Jun 2021 13:02:05 +0100
> Subject: RE: [PVE-User] E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
> ===========
> >>On Thu, Jun 24, 2021 at 2:50 AM <proxmox at elchaka.de> wrote:
> >>
> >> Did you tried something like
> >>
> >> apt -f install
> >
> >Tried by failed. See the screenshot in attachment.
> >
> >HY
> ===========
>
> (sorry I'm using Outlook and not configured correctly for mailing list
> replies)
>
> If you are using the console within Proxmox, maybe try connecting via ssh
> instead.
>
> I know that sounds crazy, but I had similar issues on PBS (as opposed to
> proxmox) where dpkg --configure -a caused the console to sort of crash or
> freeze and the command didn't actually complete.
>
> Doing it via ssh instead resolved the problem.
>
> I can't see your screen shots, and you mentioned "doesn't work" as opposed
> to "console does something strange" so maybe this is of no help whatsoever.

See the following info seen from the console/shell within Proxmox web UI:

root at pve:~# apt -f install
E: dpkg was interrupted, you must manually run 'dpkg --configure -a'
to correct the problem.


And the following info seen under ssh terminal:

werner at X10DAi:~$ ssh root at 192.168.10.254
The authenticity of host '192.168.10.254 (192.168.10.254)' can't be established.
ECDSA key fingerprint is SHA256:s6hATbCfE+vH/h2HBl2RcKJM4xHwjfXiF5mt/c8igog.
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added '192.168.10.254' (ECDSA) to the list of known hosts.
root at 192.168.10.254's password:
Linux pve 5.4.73-1-pve #1 SMP PVE 5.4.73-1 (Mon, 16 Nov 2020 10:52:16
+0100) x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Jun 24 21:36:35 2021
root at pve:~# apt -f install
E: dpkg was interrupted, you must manually run 'dpkg --configure -a'
to correct the problem.
root at pve:~#

HY
>
>
>
> ---------- Forwarded message ----------
> From: Faris Raouf via pve-user <pve-user at lists.proxmox.com>
> To: "'Proxmox VE user list'" <pve-user at lists.proxmox.com>
> Cc: Faris Raouf <asterisk at raouf.net>
> Bcc:
> Date: Thu, 24 Jun 2021 13:02:05 +0100
> Subject: Re: [PVE-User] E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
> _______________________________________________
> pve-user mailing list
> pve-user at lists.proxmox.com
> https://lists.proxmox.com/cgi-bin/mailman/listinfo/pve-user



-- 
Assoc. Prof. Hongyi Zhao <hongyi.zhao at gmail.com>
Theory and Simulation of Materials
Hebei Vocational University of Technology and Engineering
NO. 552 North Gangtie Road, Xingtai, China



More information about the pve-user mailing list