[PVE-User] Tape Drive Pass Through into PBS VM

Samuel Lorch sam at lorch.net
Mon Jul 26 11:32:07 CEST 2021


On 26.07.2021 11:06, Dominik Csapak wrote:
> On 7/26/21 10:50 AM, Samuel Lorch wrote:
>> Hello,
>> 
>> i Have been trying to pass through a TC-L52BN LTO 5 Tape Drive from 
>> Quantum that's connected to a MegaRaid SAS 1068 LSI Raid Card, this 
>> setup works if i have a bare metal installed Proxmox Backup Server. I 
>> Have IOMMU Enabled on the Proxmox Host and Passed through the Raid 
>> Card to the VM. I can Also see the Raid Card With "lspci" from inside 
>> the VM but the "proxmox-tape drive scan" command and the UI can't seem 
>> to find it. Is there Any Additional Setup i have to do / any 
>> Troubleshooting steps i could follow?
>> 
>> Thanks,
>> Samuel
>> 
> 
> Hi,
> 
> did not try such a setup myself, but is the passthrough properly
> working? I.e. do you see any other disks that are connected?
> 
> Is the correct driver loaded for the raid card?
> 
> Also what does 'dmesg' show?
> 
> kind regards
> Dominik

Hi,

unfortunately this raid controller only has external ports and i don't 
have a adapter to directly attach a drive.

The driver seems to load correctly according to dmesg, here are some 
parts i believe are related, if there are any that i missed please ask:

[    2.179335] megasas: 07.714.04.00-rc1
[    2.181559] megaraid_sas 0000:06:10.0: BAR:0x0  BAR's 
base_addr(phys):0x00000000c1620000  mapped virt_addr:0x(____ptrval____)
[    2.181575] i801_smbus 0000:00:1f.3: Enabling SMBus device
[    2.181584] megaraid_sas 0000:06:10.0: Waiting for FW to come to 
ready state
...
[   34.777774] megaraid_sas 0000:06:10.0: FW now in Ready state
[   34.777799] megaraid_sas 0000:06:10.0: 63 bit DMA mask and 32 bit 
consistent mask
[   34.778149] megaraid_sas 0000:06:10.0: current msix/online cpus      
: (0/4)
[   34.778153] megaraid_sas 0000:06:10.0: RDPQ mode     : (disabled)
[   34.861766] megaraid_sas 0000:06:10.0: controller type       : 
MR(256MB)
[   34.861769] megaraid_sas 0000:06:10.0: Online Controller Reset(OCR)  
: Enabled
[   34.861771] megaraid_sas 0000:06:10.0: Secure JBOD support   : No
[   34.861773] megaraid_sas 0000:06:10.0: NVMe passthru support : No
[   34.861774] megaraid_sas 0000:06:10.0: FW provided TM TaskAbort/Reset 
timeout        : 0 secs/0 secs
[   34.861776] megaraid_sas 0000:06:10.0: JBOD sequence map support     
: No
[   34.861778] megaraid_sas 0000:06:10.0: PCI Lane Margining support    
: No
[   34.861780] megaraid_sas 0000:06:10.0: megasas_init_mfi: 
fw_support_ieee=0
[   34.861917] megaraid_sas 0000:06:10.0: INIT adapter done
[   34.861920] megaraid_sas 0000:06:10.0: JBOD sequence map is disabled 
megasas_setup_jbod_map 5707
[   34.861939] megaraid_sas 0000:06:10.0: MR_DCMD_PD_LIST_QUERY not 
supported by firmware
[   34.861976] megaraid_sas 0000:06:10.0: fw state:c0000000
[   34.861979] megaraid_sas 0000:06:10.0: fwstate:c0000000, dis_OCR=0
[   34.889759] megaraid_sas 0000:06:10.0: DCMD not supported by firmware 
- megasas_ld_list_query 4829
[   34.917783] megaraid_sas 0000:06:10.0: pci id                : 
(0x1000)/(0x0411)/(0x1000)/(0x1002)
[   34.917787] megaraid_sas 0000:06:10.0: unevenspan support    : no
[   34.917788] megaraid_sas 0000:06:10.0: firmware crash dump   : no
[   34.917789] megaraid_sas 0000:06:10.0: JBOD sequence map     : 
disabled
[   34.917794] megaraid_sas 0000:06:10.0: Max firmware commands: 1007 
shared with nr_hw_queues = 1
[   34.917806] scsi host0: Avago SAS based MegaRAID driver
...
[   36.300625] iscsi: registered transport (tcp)
...
[   36.336130] iscsi: registered transport (iser)
...
[  107.713269] megaraid_sas 0000:06:10.0: MR_DCMD_PD_LIST_QUERY not 
supported by firmware

Note: Before on the PBS that was installed on Hardware i could only get 
the Drive to show up if the Drive was powered up and plugged in before 
starting the Backup Server, Could this be Causing Issues?

regards
Samuel



More information about the pve-user mailing list