[PVE-User] LXC mount point not in backup

Petric Frank pfrank at gmx.de
Fri Jan 29 13:36:15 CET 2021


Hello,

in my config i have a mountp point defined as:

  mp0: /storage/nextcloud-gz,mp=/nextcloud,ro=0,backup=1

Despite the option "backup=1" it is not included in an backup. The backup screen log:
--------------------------- cut --------------------------
INFO: starting new backup job: vzdump 200 --compress gzip --node proxmox-gz --remove
0 --mode stop --storage zfs-raid
INFO: filesystem type on dumpdir is 'zfs' -using /var/tmp/vzdumptmp31209_200 for
temporary files
INFO: Starting Backup of VM 200 (lxc)
INFO: Backup started at 2021-01-29 13:23:05
INFO: status = stopped
INFO: backup mode: stop
INFO: ionice priority: 7
INFO: CT Name: nextcloud
INFO: including mount point rootfs ('/') in backup
INFO: excluding bind mount point mp0 ('/nextcloud') from backup (not a volume)
INFO: creating vzdump archive '/storage/vz/dump/vzdump-
lxc-200-2021_01_29-13_23_05.tar.gz'
INFO: Total bytes written: 3123005440 (3.0GiB, 21MiB/s)
INFO: archive file size: 1.39GB
INFO: Finished Backup of VM 200 (00:02:27)
INFO: Backup finished at 2021-01-29 13:25:32
INFO: Backup job finished successfully
TASK OK
--------------------------- cut --------------------------

As you can see the line below states that as "not a volume":
INFO: excluding bind mount point mp0 ('/nextcloud') from backup (not a volume)

Is there a way to include the mount point in a backup ?

Additional question: What is the behaviour of PBS in this case ?


kind regards
  Petric



More information about the pve-user mailing list