[PVE-User] Error building pve-qemu-kvm from source

Stefan Reiter s.reiter at proxmox.com
Tue Aug 31 09:46:50 CEST 2021


Hi!

I just tried a clean build on a fresh Debian 11 container with the exact 
steps described by you, and it built me a .deb just fine. Even with the 
'sed' command it worked, including PA support.

Can you provide a bit more detail about your build environment? Have you 
configured the PVE APT repos on your host (for 
'libproxmox-backup-qemu0-dev') before doing 'mk-build-deps'?

As a shot in the dark, since the missing file is generated by a python 
script, maybe you're running into a Python 2/3 mixup somewhere?

As for inclusion, I believe one of the points would be the dependency on 
pulseaudio (at least the libs) when compiled into QEMU, which I _think_ 
we don't have right now. Wouldn't be too much of an issue though imo...

~ Stefan


On 31/08/2021 04:30, Musee Ullah via pve-user wrote:
> _______________________________________________
> pve-user mailing list
> pve-user at lists.proxmox.com
> https://lists.proxmox.com/cgi-bin/mailman/listinfo/pve-user
> 




More information about the pve-user mailing list