[PVE-User] Error building pve-qemu-kvm from source

Musee Ullah lae at lae.is
Tue Aug 31 11:39:13 CEST 2021

I think my repos are configured appropriately, as that package is 
found/was installed as expected:

$ apt search libproxmox-backup-qemu0-dev
Sorting... Done
Full Text Search... Done
libproxmox-backup-qemu0-dev/stable,now 1.2.0-1 amd64 [installed,automatic]
   Proxmox Backup Server client library for QEMU development files

$ cat /etc/apt/sources.list.d/proxmox.list
deb http://download.proxmox.com/debian/pve bullseye pve-no-subscription
deb http://download.proxmox.com/debian/devel/ bullseye main

No other repos configured other than a debian mirror for bullseye 
(debian, debian security and updates).

Both Python 2.7 and 3.9 are installed, but qapi-gen.py does specify py3 
and that seems to be fine...

$ env /usr/bin/python3 -V
Python 3.9.2

This host was deployed with PVE 6 using my Ansible role (lae.proxmox), 
and upgraded to PVE 7 via apt. Package/installation wise it hasn't been 
touched outside of that until I attempted to set it up for a build (and 
added the devel repo above during troubleshooting).

Do you have any other ideas what might be causing it?

Either way, seeing as it *should* be building with those steps, I guess 
I'll try building it inside a new host. Thanks for confirming.

On 8/31/21 2:46 AM, Stefan Reiter wrote:
> Hi!
> I just tried a clean build on a fresh Debian 11 container with the 
> exact steps described by you, and it built me a .deb just fine. Even 
> with the 'sed' command it worked, including PA support.
> Can you provide a bit more detail about your build environment? Have 
> you configured the PVE APT repos on your host (for 
> 'libproxmox-backup-qemu0-dev') before doing 'mk-build-deps'?
> As a shot in the dark, since the missing file is generated by a python 
> script, maybe you're running into a Python 2/3 mixup somewhere?
> As for inclusion, I believe one of the points would be the dependency 
> on pulseaudio (at least the libs) when compiled into QEMU, which I 
> _think_ we don't have right now. Wouldn't be too much of an issue 
> though imo...
> ~ Stefan

-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature
Type: application/pgp-signature
Size: 236 bytes
Desc: OpenPGP digital signature
URL: <http://lists.proxmox.com/pipermail/pve-user/attachments/20210831/e3c9048f/attachment.sig>

More information about the pve-user mailing list