[PVE-User] Problem with ifupdown2

Jean-Daniel TISSOT Jean-Daniel.Tissot at univ-fcomte.fr
Wed Sep 9 13:05:36 CEST 2020


Hi,

I installed the ifupdown2 package from the Proxmox repositories, this 
uninstalled the ifenslave and ifupdown packages.
I usually uninstall configuration residue from packages deleted by the 
command:
apt -y purge $(dpkg -l | awk ' /^rc/ { print $2 } ')
or after reboot, the network interfaces are no longer active

The command: dpkg -L ifenslave lists the following files:
/etc/network/if-post-down. d
/etc/network/if-post-down. d/ifenslave
/etc/network/if-pre-up. d
/etc/network/if-pre-up. d/ifenslave
/etc/network/if-up. d
/etc/network/if-up. d/ifenslave

The command: dpkg -L ifupdown lists the following files:
/etc/init. d/networking

How is it that the ifupdown2 package does not contain these files since 
its installation removes the ifenslave and ifupdown packages?

Thanks to the developers to include the files necessary for the proper 
functioning of ifupdown2.

Best Regards.

-- 
Bien cordialement,
Jean-Daniel Tissot - IE CNRS     http://chrono-environnement.univ-fcomte.fr
UMR 6249 - Laboratoire Chrono-environnement                    UMR CNRS-UFC
Université de Franche-Comté, 16 route de Gray, 25030 Besançon Cedex, FRANCE
Jean-Daniel.Tissot at univ-fcomte.fr                      tel:+33 3 81 666 440
Mobile personnel                                          +33 6 51 94 35 83



More information about the pve-user mailing list