[PVE-User] Caution: ceph-mon service does not start after today's updates

Thomas Lamprecht t.lamprecht at proxmox.com
Thu Nov 26 15:46:00 CET 2020


On 26.11.20 15:15, Uwe Sauter wrote:
> Am 26.11.20 um 15:10 schrieb Lindsay Mathieson:
>> On 26/11/2020 10:18 pm, Uwe Sauter wrote:
>>> this is a warning for all that are eager to apply today's updates.
>>> In my case the ceph-mon@<host> service did not start after a reboot which caused a hanging Ceph once the second monitoring service
>>> went offline.
>>
>> I ran into that, also the node failed to rejoin the cluster quorum. syslog had errors relating to the pem-ssl key.
>>
>> Manually start the pve cluster service and a 2nd reboot solved both issues.
>>
> 
> Yes, rebooting might help, but not reliably. I had nodes that needed several reboots until pvestatd did not fail.
> 
> I also had failed ceph-mgr@<host> services (with Nautilus).
> 
> My current suspicion is that my network takes too long to become available.
> 

Note, it's always good idea to check if all services are running OK again before
continuing with upgrading the next host, not just on this update :-)

Also, ceph monitors can be nicely restarted over the web interface, there's a
visible status about which services run outdated versions/need a restart.


Anyway, do you have any logs which could give more details for possible issues?

regards,
Thomas





More information about the pve-user mailing list