[PVE-User] Network hardware tuning and bond...

Marco Gaiarin gaio at sv.lnf.it
Fri Nov 6 17:30:03 CET 2020


[Probably it is all but a specific PVE question, but...]

I need to setup a PVE standalone node that have to host some VMs, one
of that have to be a 'firewall'; one or more NICs are dedicated to WAN
link.


Following the 'bufferbloat' recommendation:

	https://www.bufferbloat.net/projects/bloat/wiki/Tests_for_Bufferbloat/

i've added to a typical bridge:

 iface enp2s0f1 inet manual
	ethernet-autoneg on
	link-speed 100
	link-duplex full
	hardware-dma-ring-tx 18
	offload-tso off
	offload-gso off
	offload-gro off

 auto vmbr1
 iface vmbr1 inet static
	address 172.17.44.50
	netmask 255.255.255.0
	gateway 172.17.44.1
	bridge_ports enp2s0f1
	bridge_waitport 30
	bridge_stp off
	bridge_fd 0

and seems to work, eg link speed is 100Mbit/s and offload parameters
are off.


But i've tried to do the same thing with an LACP bond, adding this parameters
both to single interfaces and also on the bond interface, but seems get
ignored.


It is not possible to set hardware parameters in bond and/or in bond
members?!


Thanks.

-- 
dott. Marco Gaiarin				        GNUPG Key ID: 240A3D66
  Associazione ``La Nostra Famiglia''          http://www.lanostrafamiglia.it/
  Polo FVG   -   Via della Bontà, 7 - 33078   -   San Vito al Tagliamento (PN)
  marco.gaiarin(at)lanostrafamiglia.it   t +39-0434-842711   f +39-0434-842797

		Dona il 5 PER MILLE a LA NOSTRA FAMIGLIA!
      http://www.lanostrafamiglia.it/index.php/it/sostienici/5x1000
	(cf 00307430132, categoria ONLUS oppure RICERCA SANITARIA)



More information about the pve-user mailing list