[PVE-User] Backup broken?

Bernhard Dick bernhard at bdick.de
Mon Nov 2 10:17:10 CET 2020


Hi,

Am 01.11.2020 um 20:48 schrieb Thomas Lamprecht:
> On 01.11.20 14:14, Bernhard Dick wrote:
>> I can even reproduce this behaviour by triggering the global Backup job from the web console. If I backup single VMs/Containers from the Host part of the web console it runs fine, however the global job removes also those backups when it is running.
> 
> Yes, there was a regression with this when adopting the newer prune "keep-daily",
> "keep-weekly", ... logic. It acts quite different internally, but the storage
> special case for maxfiles==0 was handled rather implicit, thus this did not
> rang any alarm bells. I transformed it to a more explicit logic and we'll
> add some more extensive test for this special case, so that it won't happen again.
> 
> The fix is packaged in pve-manager version 6.2-15, currently available on pvetest.
> You can either add the pvetest repository[0], do `apt update && apt install pve-manager`,
> then drop the test repo again, or manually download and install it, with using
> `apt install` this still checks if the package is valid (i.e., signed by a trusted
> key):
> 
> # wget http://download.proxmox.com/debian/pve/dists/buster/pvetest/binary-amd64/pve-manager_6.2-15_amd64.deb
> # apt install ./pve-manager_6.2-15_amd64.deb
> 
I tried it now and it works as expected. So thanks for fixing this fast.

   Regards
     Bernhard

> thanks for your report!
> 
> regards,
> Thomas
> 
> 
> [0]: https://pve.proxmox.com/wiki/Package_Repositories
> 
> 



More information about the pve-user mailing list