[PVE-User] qm import stuck

Gilberto Nunes gilberto.nunes32 at gmail.com
Tue Jan 21 16:00:13 CET 2020


Hi there
I am using pve 6 all update (pve-no-sub)...
I have a Dell Storage MD3200i and have set up multipath...
But when try to import a disk into lvm created over multipath, I stuck:
qm importdisk 108 vm-107-disk-0.raw VMDATA
importing disk 'vm-107-disk-0.raw' to VM 108 ...
trying to acquire cfs lock 'storage-VMDATA' ...
trying to acquire cfs lock 'storage-VMDATA' ...
  Logical volume "vm-108-disk-0" created.
transferred: 0 bytes remaining: 107374182400 bytes total: 107374182400
bytes progression: 0.00 %

I get some messages in dmesg:

74394] sd 15:0:0:0: rdac: array Storage_Abatex, ctlr 0, queueing
MODE_SELECT command
[63033.074899] sd 15:0:0:0: rdac: array Storage_Abatex, ctlr 0, MODE_SELECT
returned with sense 06/94/01
[63033.074902] sd 15:0:0:0: rdac: array Storage_Abatex, ctlr 0, retrying
MODE_SELECT command
[63033.519329] sd 16:0:0:0: rdac: array Storage_Abatex, ctlr 0, queueing
MODE_SELECT command
[63033.519835] sd 16:0:0:0: rdac: array Storage_Abatex, ctlr 0, MODE_SELECT
returned with sense 06/94/01
[63033.519836] sd 16:0:0:0: rdac: array Storage_Abatex, ctlr 0, retrying
MODE_SELECT command

This is the multpath file:
cat /etc/multipath.conf
defaults {
        polling_interval 3
        path_selector "round-robin 0"
        max_fds "max"
        path_grouping_policy multibus
        uid_attribute "ID_SERIAL"
        rr_min_io 100
        failback immediate
        no_path_retry queue
        }

blacklist {
        wwid .*
devnode "^sda"
device {
                vendor "DELL"
                product "Universal Xport"
        }
}
devices {
device {
                vendor "DELL"
                product "MD32xxi"
                path_grouping_policy group_by_prio
                prio rdac
                #polling_interval 5
                path_checker rdac
                path_selector "round-robin 0"
                hardware_handler "1 rdac"
                failback immediate
                features "2 pg_init_retries 50"
                no_path_retry 30
                rr_min_io 100
                #prio_callout "/sbin/mpath_prio_rdac /dev/%n"
        }
}
blacklist_exceptions {
        wwid "361418770003f0d2800000a6c5df0a959"
}
multipaths {
        multipath {
                wwid "361418770003f0d2800000a6c5df0a959"
                alias mpath0
        }

}

The information regard Dell MD32xxi in the file above I add with the server
online... Do I need to reboot the servers or just systemctl restart
multipath-whatever???

Thanks for any help

---
Gilberto Nunes Ferreira

(47) 3025-5907
(47) 99676-7530 - Whatsapp / Telegram

Skype: gilberto.nunes36


More information about the pve-user mailing list