[PVE-User] Can't start VM

leesteken at pm.me leesteken at pm.me
Mon Feb 10 17:04:32 CET 2020


‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Monday, February 10, 2020 4:49 PM, Gerald Brandt <gbr at majentis.com> wrote:

> Hi,
>
> I have a small cluster of 4 servers. One server in the cluster seems to
> be having an issue. For the last two weeks, one or two of the VMs seem
> to psuedo lock up over the weekend. I can still VNC in and type in a
> login, but after typing the password, the system never responds. Also,

I've seen this exact behavior if the memory inside the VM is full.
It sound like the system cannot start a login shell.
If you are using ballooning, it might let you login if you increase the
available memory in the VM using the Monitor: info balloon.

> all services on that VM (web, version control) are non-responsive. A
> reset from VM console doesn't work, I need to do a stop and start.
>
> However, on start, I get this from the Proxmox server, and the VM never
> starts:
>
> Feb 10 09:29:32 proxmox-2 pvedaemon[1142]: start VM 107:
> UPID:proxmox-2:00000476:0311D642:5E4176DC:qmstart:107:root at pam:
> Feb 10 09:29:32 proxmox-2 pvedaemon[16365]: root at pam starting task
> UPID:proxmox-2:00000476:0311D642:5E4176DC:qmstart:107:root at pam:
> Feb 10 09:29:34 proxmox-2 systemd[1]: Started Session 266 of user root.
> Feb 10 09:29:35 proxmox-2 qm[1236]: VM 107 qmp command failed - VM 107
> not running
> Feb 10 09:29:37 proxmox-2 pvedaemon[1142]: timeout waiting on systemd
> Feb 10 09:29:37 proxmox-2 pvedaemon[16365]: root at pam end task
> UPID:proxmox-2:00000476:0311D642:5E4176DC:qmstart:107:root at pam: timeout
> waiting on system
>
> I have to migrate all the VMs off the server and reboot the server. Any
> ideas?

Sorry, I have no experience with clusters.
Would Proxmox not do this automatically when you shutdown the node?

kind regards, Arjen



More information about the pve-user mailing list