[PVE-User] Can't start VM

Gerald Brandt gbr at majentis.com
Mon Feb 10 16:49:28 CET 2020


Hi,

I have a small cluster of 4 servers. One server in the cluster seems to 
be having an issue. For the last two weeks, one or two of the VMs seem 
to psuedo lock up over the weekend. I can still VNC in and type in a 
login, but after typing the password, the system never responds. Also, 
all services on that VM (web, version control) are non-responsive. A 
reset from VM console doesn't work, I need to do a stop and start.


However, on start, I get this from the Proxmox server, and the VM never 
starts:

Feb 10 09:29:32 proxmox-2 pvedaemon[1142]: start VM 107: 
UPID:proxmox-2:00000476:0311D642:5E4176DC:qmstart:107:root at pam:
Feb 10 09:29:32 proxmox-2 pvedaemon[16365]: <root at pam> starting task 
UPID:proxmox-2:00000476:0311D642:5E4176DC:qmstart:107:root at pam:
Feb 10 09:29:34 proxmox-2 systemd[1]: Started Session 266 of user root.
Feb 10 09:29:35 proxmox-2 qm[1236]: VM 107 qmp command failed - VM 107 
not running
Feb 10 09:29:37 proxmox-2 pvedaemon[1142]: timeout waiting on systemd
Feb 10 09:29:37 proxmox-2 pvedaemon[16365]: <root at pam> end task 
UPID:proxmox-2:00000476:0311D642:5E4176DC:qmstart:107:root at pam: timeout 
waiting on system


I have to migrate all the VMs off the server and reboot the server. Any 
ideas?


Gerald


# pveversion --verbose
proxmox-ve: 5.4-2 (running kernel: 4.15.18-24-pve)
pve-manager: 5.4-13 (running version: 5.4-13/aee6f0ec)
pve-kernel-4.15: 5.4-12
pve-kernel-4.15.18-24-pve: 4.15.18-52
pve-kernel-4.15.18-21-pve: 4.15.18-48
pve-kernel-4.15.18-18-pve: 4.15.18-44
pve-kernel-4.15.18-13-pve: 4.15.18-37
pve-kernel-4.15.18-12-pve: 4.15.18-36
pve-kernel-4.15.18-11-pve: 4.15.18-34
pve-kernel-4.15.18-10-pve: 4.15.18-32
pve-kernel-4.15.18-7-pve: 4.15.18-27
pve-kernel-4.15.18-5-pve: 4.15.18-24
pve-kernel-4.15.18-4-pve: 4.15.18-23
pve-kernel-4.15.17-3-pve: 4.15.17-14
pve-kernel-4.13.13-5-pve: 4.13.13-38
pve-kernel-4.13.13-2-pve: 4.13.13-33
pve-kernel-4.13.4-1-pve: 4.13.4-26
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-12
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-56
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-14
libpve-storage-perl: 5.0-44
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-7
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
proxmox-widget-toolkit: 1.0-28
pve-cluster: 5.0-38
pve-container: 2.0-41
pve-docs: 5.4-2
pve-edk2-firmware: 1.20190312-1
pve-firewall: 3.0-22
pve-firmware: 2.0-7
pve-ha-manager: 2.0-9
pve-i18n: 1.1-4
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 3.0.1-4
pve-xtermjs: 3.12.0-1
qemu-server: 5.0-55
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.13-pve1~bpo2



More information about the pve-user mailing list