PVE 6.1 upgrade and iSCSI

Stefan M. Radman smr at kmi.com
Tue Feb 4 16:26:09 CET 2020


Just wanted to share an experience made during a recent upgrade to 6.1 of a node that uses iSCSI storage.

The upgrade ultimately failed because dpkg refused to upgrade the open-iscsi package due to a failure in the postinst script of the open-iscsi package.

See the installation log below for details.

The problem was a failed iSCSI session (1 out of 4).
Only after fixing the source of the issue (a duplicate IP address on the storage VLAN!) was I able to restart and complete the upgrade.

Lesson learned: better have your logs clean before the upgrade to 6.x or your problems won't get less.

Stefan
PS: and run pve5to6 until no failures and no warnings..

root at proxmox:~# apt dist-upgrade
.
.
Setting up open-iscsi (2.0.874-7.1) ...
open-iscsi postinst: since the check in preinst some iSCSI sessions have
                     failed. -> will wait 30s for automatic recovery
open-iscsi postinst: some sessions are still in failed state -> iscsid
                     will be restarted regardless, since that may
                     actually help with the session recovery.
dpkg: error processing package open-iscsi (--configure):
 installed open-iscsi package post-installation script subprocess returned error exit status 1
.
.
Errors were encountered while processing:
 open-iscsi
E: Sub-process /usr/bin/dpkg returned an error code (1)
root at proxmox:~#





CONFIDENTIALITY NOTICE: This communication may contain privileged and confidential information, or may otherwise be protected from disclosure, and is intended solely for use of the intended recipient(s). If you are not the intended recipient of this communication, please notify the sender that you have received this communication in error and delete and destroy all copies in your possession.


More information about the pve-user mailing list