[PVE-User] LVM over ISCSI issue

Amin Vakil info at aminvakil.com
Wed Aug 12 15:05:25 CEST 2020


>> Do you have any reason leading you to believe enabling discard is the
>> problem?
>>
>
> I was mainly driven by search results on the internet based on
> "0x9:(WRITE_ZEROES) flags 0x0 phys_seg 0" as keywords.
>
>>> kernel: sd 1:0:0:0: [sdb] tag#74 Add. Sense: Logical unit communication
> failure
>
> This also suggests that the (iscsi?) communication between the initiator
> and the target was lost for some reason.
> Can you check on iscsi target (NAS) logs for any clues at the same time?
> If possible, you could try separating iscsi network from nfs network or
> even rolling back to a previous pve kernel to see if that will help.

I use NFS only for backups which happens at night, so there isn't any
write on NFS.

There isn't any useful log on qnap NAS, but most of times its RAM is
full and it doesn't have any cache. Maybe qnap prevents writing when
it's fully used and maybe proxmox thinks it has complete access over
/dev/sdb and therefore when it sees it cannot write gives an
input/output error.

Isn't there a tweak in proxmox to retry writing on iscsi until it succeeds?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.proxmox.com/pipermail/pve-user/attachments/20200812/9ef1e27d/attachment-0001.sig>


More information about the pve-user mailing list