[PVE-User] running Debian 10 containers in PVE 5.4

Thomas Lamprecht t.lamprecht at proxmox.com
Tue Oct 15 13:01:39 CEST 2019


Hi,

On 10/15/19 11:58 AM, Adam Weremczuk wrote:
> Hello,
> 
> I'm running PVE 5.4-13 (Debian 9.11 based) using free no-subscription repos.
> 
> Recently I've deployed a few Debian 10.0 containers which I later upgraded to 10.1.
> 
> I'm having constant issues with these CTs such as delayed start and console availability (up to 15 minutes), unexpected network disconnections etc.
> 
> No such issues for Debian 9.x containers.
> 
> Is running Debian 10.x over 9.11 officially supported?

Somewhat, but the relative new systemd inside Debian 10 and other
newer distros is not always that compatible with current Container
Environments.

As a starter I'd enable the "nesting" feature in the CTs options, it
should help for quite a few issues by allowing systemd to setup it's
own cgroups in the CT. This option can only be done as root, and while
it has no real security implications it still exposes more of the host
in the CT.

There's some work underway to improve the CT experience with newer
distribution versions, but that will need still quite a bit of time and
will only become available on the PVE 6.X series, AFAICT.

> 
> Will switching to paid community repositories greatly improve my experience?

No, while the enterprise version is surely more stable it has not more
features than the community ones.

cheers,
Thomas



More information about the pve-user mailing list