[PVE-User] upgrade smartmon tools?

Thomas Lamprecht t.lamprecht at proxmox.com
Tue Oct 1 08:19:13 CEST 2019


Hi,

On 10/1/19 4:08 AM, Roberto Alvarado wrote:
> Hi Folks,
> 
> Do you know what is the best way to upgrade the smartmon tools package to version 7?
> 

just upgrade to Proxmox VE 6.x, it has smartmontools 7:

# apt show smartmontools
Package: smartmontools
Version: 7.0-pve2

For now we have no plans to backport it to 5.4.

> I have some problems with nvme units and smartmont 6.x, but with the 7 version all works without problem, but some proxmox packages depends on smartmon and I dont want to create a problem with this update.

You could re-build it yourself from our git[0] if you really cannot upgrade
and ain't scared from installing some dev packages and executing some `make` :)

# git clone git://git.proxmox.com/git/smartmontools.git
# cd smartmontools
# make submodule
# make deb

[0]: https://git.proxmox.com/?p=smartmontools.git;a=summary

cheers,
Thomas



More information about the pve-user mailing list