[PVE-User] core packages held back

Christian Ebner c.ebner at proxmox.com
Wed May 29 17:52:35 CEST 2019


Hi,
please run a apt-get dist-upgrade, not just an apt-get upgrade.

See man apt-get:
dist-upgrade
dist-upgrade in addition to performing the function of upgrade, also intelligently handles changing dependencies with new versions of packages; apt-get has a "smart" conflict resolution system, and it will attempt to upgrade the most important packages at the expense of less important ones if necessary. The dist-upgrade command may therefore remove some packages. The /etc/apt/sources.list file contains a list of locations from which to retrieve desired package files. See also apt_preferences(5) for a mechanism for overriding the general settings for individual packages.

Hope this helps!

> On May 29, 2019 at 5:32 PM Adam Weremczuk <adamw at matrixscience.com> wrote:
> 
> 
> Hi all,
> 
> I've just downloaded and installed the latest PVE 5.4.
> 
> I use free repos:
> 
> deb http://download.proxmox.com/debian/pve stretch pve-no-subscription
> 
> Upon running apt-get update / upgrade I got:
> 
> The following packages have been kept back:
>    pve-kernel-4.15 pve-manager
> 
> apt list --upgradable
> Listing... Done
> pve-kernel-4.15/stable 5.4-3 all [upgradable from: 5.3-3]
> pve-manager/stable 5.4-6 amd64 [upgradable from: 5.4-3]
> 
> Shall I remove the holds and upgrade the packages or keep them version 
> locked and for how long?
> 
> Thanks,
> Adam
> 
> 
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user



More information about the pve-user mailing list