[PVE-User] Proxmox Virtual Environment 5.3-8

Nicola Ferrari (#554252) nick-liste at posteo.eu
Wed May 8 09:20:06 CEST 2019


Il 08/05/2019 08:57, Muhammad Monowar Hossain ha scritto:
>>> 1. Live migration is not working from GUI
>>
>> What kind of problem/error are you experiencing?
> 
> 2019-05-08 06:54:18 starting migration of VM 115 to node 'HV-02’ (x.x.x.x)
> 2019-05-08 06:54:18 found local disk 'vmdata:vm-115-disk-0' (in current VM config)
> 2019-05-08 06:54:18 can't migrate local disk 'vmdata:vm-115-disk-0': can't live migrate attached local disks without with-local-disks option
> 2019-05-08 06:54:18 ERROR: Failed to sync data - can't migrate VM - check log
> 2019-05-08 06:54:18 aborting phase 1 - cleanup resources
> 2019-05-08 06:54:18 ERROR: migration aborted (duration 00:00:01): Failed to sync data - can't migrate VM - check log
> TASK ERROR: migration aborted
> 

That's because you are using local disks.
Usually live migration expects you use some kind of shared storage
beetween nodes, so there's no disk to migrate..

In your case you need to copy also disk image beetween nodes, so, as far
as I now, at the moment the only way to force this is using shell command

See:
https://forum.proxmox.com/threads/live-migration-with-local-storage-gives-an-error.37762/

Anyway, I really suggest you to create/introduce some kind of shared
storage if you have more than 1 node..

Cheers!
N

-- 
+---------------------+
| Linux User  #554252 |
+---------------------+



More information about the pve-user mailing list