[PVE-User] Proxmox - BIG PROBLEM

lord_Niedzwiedz sir_Misiek1 at o2.pl
Mon Jul 29 11:08:37 CEST 2019


         VM at local-zfs.
But local-zfs not available with gui !!
VM still work.

And I see in:
cd /mnt/pve/
directory:
nvme0n1 / nvme1n1 / sda /

Here is one virtual.
The rest on local-zfs (and they work, and I can not see the space).

Proxmox it's still working.

I lostmybe only :
/bin
/lib
/lib64
/sbin
How is it possible that command:
rm / *
removed them ?? !!

Without the -r option.

And the rest of the catalogs did not delete ?? !!
Maybe these were symbolic links?

Gregor
> Where are located the VM's disks ? LVM ? ZFS ?
> Is possibile that you still have your disks (if LVM, for example), but i think that is better that you install a fresh Proxmox server, and move the disks from the old hard drive to the new one.
> You need some knowledge about linux, lvm, and you can save all your data.
>
>
>
> ----- Il 29-lug-19, alle 10:55, lord_Niedzwiedz sir_Misiek1 at o2.pl ha scritto:
>
>> I ran a command on the server by mistake:
>>
>> rm /*
>> rm: cannot remove '/Backup': Is a directory
>> rm: cannot remove '/boot': Is a directory
>> rm: cannot remove '/dev': Is a directory
>> rm: cannot remove '/etc': Is a directory
>> rm: cannot remove '/home': Is a directory
>> rm: cannot remove '/media': Is a directory
>> rm: cannot remove '/mnt': Is a directory
>> rm: cannot remove '/opt': Is a directory
>> rm: cannot remove '/proc': Is a directory
>> rm: cannot remove '/Roboczy': Is a directory
>> rm: cannot remove '/root': Is a directory
>> rm: cannot remove '/rpool': Is a directory
>> rm: cannot remove '/run': Is a directory
>> rm: cannot remove '/srv': Is a directory
>> rm: cannot remove '/sys': Is a directory
>> rm: cannot remove '/tmp': Is a directory
>> rm: cannot remove '/usr': Is a directory
>> rm: cannot remove '/var': Is a directory
>>
>> Strange machines work.
>> I'm logged in gui.
>> But I can not get to the machine VM.
>> Do not execute any commands.
>> What to do ??!!
>>  From what I see, I deleted my catalogs:
>> / bin
>> / lib
>> / lib64
>> / sbin
>> WITH /.
>> How is this possible ??!!
>> I'm still logged in on one console after the shell, but I can not do any
>> commandos.
>> Even:
>> qm
>> -bash: /usr/sbin/qm: /usr/bin/perl: bad interpreter: No such file or
>> directory
>> root at tomas:/usr/bin# ls
>> -bash: /usr/bin/ls: No such file or directory
>> root at tomas:/usr/bin# echo $PATH
>> /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
>>
>> Any Idea ??
>> Please Help Me.
>>
>> Gregor
>>
>> _______________________________________________
>> pve-user mailing list
>> pve-user at pve.proxmox.com
>> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user


More information about the pve-user mailing list