[PVE-User] Corosync Upgrade Issue (v2 -> v3)

Fabian Grünbichler f.gruenbichler at proxmox.com
Wed Jul 17 09:27:13 CEST 2019


On Wed, Jul 17, 2019 at 08:10:11AM +0200, Thomas Lamprecht wrote:
> On 7/16/19 11:26 PM, Chris Hofstaedtler | Deduktiva wrote:
> > * Fabian Grünbichler <f.gruenbichler at proxmox.com> [190716 21:55]:
> > [..]
> >>>
> >>> dpkg: error processing package corosync (--configure):
> >>>  dependency problems - leaving unconfigured
> >>> Processing triggers for libc-bin (2.24-11+deb9u4) ...
> >>> Processing triggers for pve-ha-manager (2.0-9) ...
> >>> Processing triggers for pve-manager (5.4-11) ...
> >>
> >> if you followed the upgrade guidelines and ONLY upgraded corosync here, these two triggers should not be triggered...
> > 
> > I've done a corosync-only upgrade the other day and the triggers are
> > indeed triggered.
> 
> Yes, and that's correct. We actively trigger the pve-cluster (pmxcfs) service
> and the "pve-api-updates" trigger - which then trigger manager and ha-manager.
> 
> Se, and the in-lined commit message for details (basically new libqb is incompat,
> as new corosync is freshly stared it load the new libqb, pmxcfs has still the old
> loaded and cannot communicate anymore, thus it needs to be restarted, and
> subsequently all daemons using IPCC calls to pmxcfs):
> 
> https://git.proxmox.com/?p=libqb.git;a=commitdiff;h=5abd5865b8d2d0cf245e4b3085a08fb22bf6e7fd

sorry for the wrong info - I indeed only checked Buster packages for
triggers, not the special Corosync 3.x Stretch packages..



More information about the pve-user mailing list