[PVE-User] Corosync Upgrade Issue (v2 -> v3)

Fabian Grünbichler f.gruenbichler at proxmox.com
Tue Jul 16 21:55:39 CEST 2019


> Ricardo Correa <r.correa.r at gmail.com> hat am 16. Juli 2019 21:28 geschrieben:
> 
>  
> Hello all,
> 
> While following the instructions for upgrade I encountered the following
> issue:
> 
> ~# systemctl stop pve-ha-lrm
> ~# systemctl stop pve-ha-crm
> ~# echo "deb http://download.proxmox.com/debian/corosync-3/ stretch main" >
> /etc/apt/sources.list.d/corosync3.list
> ~# apt update
> ...snip...
> ~# apt dist-upgrade --download-only
> ...snip...
> ~# apt dist-upgrade
> Reading package lists... Done
> ...snip...
> The following packages will be upgraded:
>   corosync libcmap4 libcorosync-common4 libcpg4 libqb0 libquorum5
> libvotequorum8
> ...snip...

please provide "unsnipped" logs, both of these commands and from the journal around the same time.

> Setting up libcorosync-common4:amd64 (3.0.2-pve2~bpo9) ...
> Processing triggers for pve-ha-manager (2.0-9) ...
> Processing triggers for man-db (2.7.6.1-2) ...
> Setting up libqb0:amd64 (1.0.5-1~bpo9+2) ...
> systemctl start pve-ha-lrmJob for pve-cluster.service failed because a
> timeout was exceeded.
> See "systemctl status pve-cluster.service" and "journalctl -xe" for details.
> dpkg: error processing package libqb0:amd64 (--configure):
>  subprocess installed post-installation script returned error exit status 1
> Setting up libknet1:amd64 (1.10-pve1~bpo9) ...
> dpkg: dependency problems prevent configuration of libvotequorum8:amd64:
>  libvotequorum8:amd64 depends on libqb0 (>= 1.0.3); however:
>   Package libqb0:amd64 is not configured yet.
> 
> dpkg: error processing package libvotequorum8:amd64 (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libcpg4:amd64:
>  libcpg4:amd64 depends on libqb0 (>= 1.0.3); however:
>   Package libqb0:amd64 is not configured yet.
> 
> dpkg: error processing package libcpg4:amd64 (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libcmap4:amd64:
>  libcmap4:amd64 depends on libqb0 (>= 1.0.3); however:
>   Package libqb0:amd64 is not configured yet.
> 
> dpkg: error processing package libcmap4:amd64 (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libquorum5:amd64:
>  libquorum5:amd64 depends on libqb0 (>= 1.0.3); however:
>   Package libqb0:amd64 is not configured yet.
> 
> dpkg: error processing package libquorum5:amd64 (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of libcfg7:amd64:
>  libcfg7:amd64 depends on libqb0 (>= 1.0.3); however:
>   Package libqb0:amd64 is not configured yet.
> 
> dpkg: error processing package libcfg7:amd64 (--configure):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of corosync:
>  corosync depends on libcfg7 (>= 2.99.5); however:
>   Package libcfg7:amd64 is not configured yet.
>  corosync depends on libcmap4 (>= 2.99.3); however:
>   Package libcmap4:amd64 is not configured yet.
>  corosync depends on libcpg4 (>= 1.1.0); however:
>   Package libcpg4:amd64 is not configured yet.
>  corosync depends on libqb0 (>= 1.0.3); however:
>   Package libqb0:amd64 is not configured yet.
>  corosync depends on libquorum5 (>= 1.99.9); however:
>   Package libquorum5:amd64 is not configured yet.
>  corosync depends on libvotequorum8 (>= 2.4.2); however:
>   Package libvotequorum8:amd64 is not configured yet.
> 
> dpkg: error processing package corosync (--configure):
>  dependency problems - leaving unconfigured
> Processing triggers for libc-bin (2.24-11+deb9u4) ...
> Processing triggers for pve-ha-manager (2.0-9) ...
> Processing triggers for pve-manager (5.4-11) ...

if you followed the upgrade guidelines and ONLY upgraded corosync here, these two triggers should not be triggered...

> Errors were encountered while processing:
>  libqb0:amd64
>  libvotequorum8:amd64
>  libcpg4:amd64
>  libcmap4:amd64
>  libquorum5:amd64
>  libcfg7:amd64
>  corosync
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> W: Operation was interrupted before it could finish
> 
> This was while updating all 3 of my nodes at the same time (taking second
> route
> of the upgrade instructions, i.e., tmuxing into all nodes while having the
> main
> tmux syncying commands). Only one of those nodes failed to update, other
> two are
> running fine right now and in quorum apparently (pvecm status says quorate:
> yes).
> 
> Right now I'm not sure how to proceed, pve-cluster in the failing node
> is looping with:
> 
> systemd[1]: Starting The Proxmox VE cluster filesystem...
> systemd[1]: pve-cluster.service: Start operation timed out. Terminating.
> pmxcfs[13267]: [main] crit: read error: Interrupted system call
> pmxcfs[13267]: [main] crit: read error: Interrupted system call
> pmxcfs[13267]: [main] notice: exit proxmox configuration filesystem (-1)
> systemd[1]: pve-cluster.service: Control process exited, code=exited
> status=255
> systemd[1]: Failed to start The Proxmox VE cluster filesystem.
> systemd[1]: pve-cluster.service: Unit entered failed state.
> systemd[1]: pve-cluster.service: Failed with result 'timeout'.
> systemd[1]: pve-cluster.service: Service hold-off time over, scheduling
> restart.
> systemd[1]: Stopped The Proxmox VE cluster filesystem.
> 
> And pmxcfs is unavailable (ls /etc/pve timeouts).
> 
> Any help is appreciated! (BTW, just joined the ML to post this, also joined
> the
> forums but can't post).
> 
> Best regards,
> Ricardo
> _______________________________________________
> pve-user mailing list
> pve-user at pve.proxmox.com
> https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-user



More information about the pve-user mailing list