[PVE-User] Host Rebooting when using PCIe Passthrough

Dominik Csapak d.csapak at proxmox.com
Fri Jul 5 08:23:15 CEST 2019


On 7/4/19 8:45 PM, Craig Jones wrote:
> Hello,
> 
> I have a VM that I'm passing a GPU through to. The passthrough itself
> works great. The issue is that whenever this VM is powered on, the host
> will reboot without any interaction from me. The reboot happens anywhere
> from 3 - 15 minutes after the VM has been powered on. I have many other
> VMs that don't cause this. The only difference between them and this one
> is the passthrough GPU. Attached are some potentially helpful outputs.
> The syslogs have been truncated from when the VM had been powered on to
> the last entry right before the host rebooted.
> 
> Thanks,
> Craig
> 
> 

one thing you could do is setup kernel crash logging (kdump) to see
if the kernel crashes and why

aside from that the only thing i see is that your gpu is not
in an isolated iommu group:

----8<----
/sys/kernel/iommu_groups/1/devices/0000:00:01.0
/sys/kernel/iommu_groups/1/devices/0000:00:01.1
/sys/kernel/iommu_groups/1/devices/0000:01:00.0
/sys/kernel/iommu_groups/1/devices/0000:01:00.1
/sys/kernel/iommu_groups/1/devices/0000:02:00.0
---->8----

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. 
[AMD/ATI] RV770 [Radeon HD 4870]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RV770 HDMI 
Audio [Radeon HD 4850/4870]
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. 
RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)

it seems it is together in a group with your nic

this can be the cause for the crashes...

hope this helps



More information about the pve-user mailing list